Schedule Creation and Filters

Hey all,

I’ve been attempting to apply a list of filters to a list of created schedules – somehow, the “filter ID” isn’t working with the applied schedules. See below for the workflow (including error) and the schedule example it is being applied to.

schedule

The filter ID that is being referenced is Pour ID, but somehow the schedule isn’t recognizing it. This problem was brought up by another user in the post below but unfortunately wasn’t resolved.

Any ideas what I could be doing wrong?

Came here to basically say what I said in the previous post you mentioned.
Unfortunately that’s not much help. :confused:

Can you show a preview of your filter values?

Of course:

These are the Pour ID’s associated with the various concrete pours in our sample project.

image

This is my goal to have for each different Pour ID in that list:

image

Each one should have a new filter made for each individual ID.

AddFilters can take lists of filters per view. So it’s trying to add all 43 filters to each view. Use levels @L1 for both inputs on ScheduleView.AddFilters.

1 Like

I’m not exactly sure what that means in this case, if they’re all in one list…

Click on the arrows for each input and set the Level to 1.
image
This will force each level one item in scheduleViews to match up with each level one item in scheduleFilters.

1 Like

Unfortunately, that gave me the same error message when I ran the script, leading me to believe it is something to do with the reference of the field ID in the schedule I am updating.

Update: I changed the ScheduleField output using a List.GetItemAtIndex node instead of dropping the first and last items from the list, and that seemed to work. I think it was a combination of the two, because at first the @L1 didn’t work. See below.

Interestingly enough, this actually is almost solved. I have to run the script twice in a row to get it to work – it keeps the same error after the first run. I’ve tried using the Cycle node to attempt to repeat the final command, but that was no good.

Any idea why it would need to run twice, when the view template (used to populate the field ID’s) runs simultaneously with the creation of the schedule filters? Since the filters are added after the template is applied, shouldn’t this work on the first run?

You could try using a transaction node and see if that helps.

Looks like that was the key! You’re a rockstar Nick, thank you.

Hi, I need to do a similar solution. Could you tell me where to add the transaction node and which node is it?

Absolutely. The transaction node can be found under the OOTB (out-of the box) nodes in the Revit dropdown, then inside the Transaction dropdown.

Hii all
I am new to dynamo i have created a room area schedule by using dynamo i got all room areas in schedule list in Revit but actually what i need is separate room areas in two different columns.
For ex: Abuilding has 5 rooms i.e., A,B,C, Deduction1 & Deduction 2 rooms. I need A,B,C areas in one columns Deduction 1 & 2 in another column in schedules is it possible to create in dynamo or any other method please help me
Thank you in advance[schedules areas.dyn|attachment]

schedules areas.dyn (31.4 KB)

Dynamo will only do what Revit allows. You can’t have multiple elements in the same row of a schedule. The only way to do this would be to have a Deductions parameter that has a deduction value for each individual room.

Thanks you so much

Hii Nick
Thank you so much for your reply and information
I tried in Revit for creating a deductions parameter but its not updated
Please help me how to create Deduction parameters and deduction value for each room it was very helpful for my project
Thank you in advance

You just have to add a parameter to your schedule for Deductions. Then, rather than creating additional rooms, you can use something like a hatch region to mark out the reduced areas and use dynamo to collect them and assign them to their respective rooms.

Thank you so much for your reply and information.

Hi Nick,
Thanks a lot for giving me reply and suggestion it was very helpful for me.
In my building i have total 5 rooms 3 rooms for total area and 2 rooms for reduced areas, But in my dynamo script by using code block iam selecting only 3 rooms as shown in below image and apply to the create schedule node but still all rooms are visible in my shedules. Is their any node to add or any other process i need only three room areasi.e, A,B,C in my schedules, Please give me suggestion and help me how to fix this issue.

Schedules Latest.dyn (31.4 KB)image
Thanks in advance

Hi Nick,
Thanks for your information, I created a hatches region for reduced area rooms and apply deduction parameter for room Schedules still deduction parameter area is not updated in schedules, Please help me how to fix this issue how to add hatch region areaa to deduction parameter in schedules by using dynamo

Schedules dynamo.dyn (43.5 KB) image