Room Points Showing Up In Plots

In trying to create a script which tags all elements of category in multiple views I’ve created 2 issues.

  1. Room location points are now visible in all views/plots - can I turn them off or make them invisible so they don’t show up in plots?
  2. My Room.Location node is returning nulls and I can’t see why I’m not able to tag all elements at the point created.


Might want to turn off background preview for Revit geometry.

Thanks John, unfortunately the issue is more that the points are in the model and visible on PDF plots.

But are they being printed as a result of the background preview being on?

Quite possibly. I turned off the preview as you suggested and they’re gone. Apologies, I’m pretty new to this.

Thanks for the help!