Room Data Sheet with Revit

Hello community,

I’m currently trying to use Revit 2022 to run the script from Rooms to Mass

to run. I am a complete newbie in Dynamo and need urgent help.
I get a lot of error messages in Dynamo. I have created a project in Revit with rooms and MEP rooms and I want to represent the rooms in 3D and create a Room Data Sheet.

Can you please help me?

Looks like you are missing Custom Packages. Use the Package Manager in Dynamo and down load the packages as annotated above the nodes.

Hi Sean,

Thanks for your answer.
Can I just install a more recent package like this?

You can install a more recent version but you run the risk of the node being updated, renamed, or removed altogether.

1 Like

Where can I download the Quasar version?

You can download old versions from the package manager too.

I recommend you read the Dynamo Primer. Lots of good information in there.


As @Steven pointed out, newer packages may have been renamed or changed in ways that will not fix your graph, and your graph may be obsolete in some ways depending on which version it was created in. Just looking at the different in version of that package makes me think your going to be in for a long ride to get it up and running especially if you are trying to run it in the latest version of Revit.


I have loaded Quasar. But there are still a few scripts missing. What name should I look for this script?


If I install all the packages with the correct version, it should work in Revit? Or What else do I need to do? This tool is very important to me.

Do you know of a newer script that I can use without much effort? Unfortunately I can’t upload my script here because the function has not been enabled yet.

Can you please help me?

I am not aware of another graph that is ready made just waiting to do exactly what you need. I still believe that with the correct packages loaded it should work, but may need some nodes replaced or removed. The Relay node may be one of those to just remove and rewire.



I untied the knots and reconnected them. Unfortunately, it does not fubktioniert. What do I have to consider with Relay? What am I doing wrong?

I can no longer install LunchBox via the package management. There is a website for that. But the website says that LunchBox is available for Grashopper

Just bypass the Relay node.

Would be great if it just worked that way. Simply delete the relay and looping the node? I will test tomorrow.

Have you already tried it?

No, but the Relay node doesn’t do anything functionally. Either update your nodes and packages so it resolves, or remove it from your script and re-wire to suit.

i give up! I can not manage to install the packages and get the script to run :frowning: