Rhythm - Select element from link Node not working?


I found the “Select element from link” Node in the Rhythm package to behave really strange. I am looking for some input to what might cause this.

When I add the node, it works perfectly fine. It looks like this:

I made a test, and created the node above. Saved the .dyn, and reopen it again. When reopening, the node looks like below:

For some reason another row of “Element” and “Transform” are added. This also causes the node to not work properly. Anyone having an idea to what might cause this?


Usually a sign of a Revit add-in causing a conflict. Disable All Revit add-ins and see if the issues persists. If not, you know one of them is the culprit and you can start re-enabling them one at a time unitl the issue repeats and then you know which add-in needs to be updated.

If the issue does persist:

  • Shut down Revit
  • Ensure that all add-ins are disabled
  • Start Revit
  • Open a project with a link in it
  • Launch Dynamo
  • Place the offending node, and select something
  • Confirm the issue persists
  • Quit Dynamo
  • Quit Revit
  • Upload your Revit journal and dynamo log from that session for review
    • Revit journal is in C:\Users\USERNAME\AppData\Local\Autodesk\Revit\Autodesk Revit 20XX\Journals\ where USERNAME is your windows username, and XX is your Revit release.
    • Dynamo log is in C:\Users\USERNAME\AppData\Roaming\Dynamo\Dynamo Revit\X.YY\Logs\ where USERNAME is your windows username, and X.YY is your Dynamo version.
    • Be sure to grab the latest timestamp for each.

For whichever Revit version you’re in, install the related rhythm version. Note: don’t click the big install button as I had to workaround the package manager for now (similar to Archi-lab):

1 Like

Thanks for the feedback!

Update: The node is working correctly when I am trying it out in one of the sample projects in Revit. I am able to select an elemt in the linked model, and the node returns the element correctly. When I then saves the .dyn script (containing only the “Select element from link” node) and reopen it, the “Element” and “Transform” -connectors are duplicated as shown in the origian post, and the node doesn’t work anymore.

The node doesn’t work within the current project thogh. When I am trying to select an elemnt within a link, the node gives me the message:
Warning: ElementSelection.InLinkDoc operation failed. Object reference not set to an instance of an object.”

Unfortnunately I am not able to share any log-files or similair, since I got this problem in a project running in a closed network environment with classified docuemtns/files (including the revitmodel). So exporting logfiles from the “inside” to the “real world” is a cumbersome process…

I imported the packages to the inside. I will double check the version of the packages, as sudgested from @john_pierson, but i am quite sure I got the correct version.

@jacob.small I will give it a try to check the Add-ins in Revit. WIll try to Disable them and see what happens.


What version of Revit and Dynamo are you in? And what is the rhythm version?

I’m in Revit 2021.1.5.
Dynamo Core:
Dynamo Revit:

I downloaded and imported both of the below Rhythm versions and tried them one at a time:

Update: When I load (link) my main Revit modell in to the Revit sample model, the node works. Not the other way around though (loading the Revit sample model in to my main revit model). I am getting more and more confused…

@john_pierson , would the version marked in the picture of the previous post be the correct ones to go for?


In your main file, do you have multiple instances of the same link?

Nope, We don’t…
Though we do have a lot of linked models (~10). I did a test with only one link in it, still didn’t work…

Throwing out some “thinking out loud” questions:
Could the file size of the model cause any problems? The main models are around 500-700mb.
Could the file path between the main model and the linked model affect the node/script?
Could the model file namne affect the node/script (We don’t have any “strange” characters)?

Started thinking in the above questions after trying to load the main model into the sample project, and the node worked. While doing it the other way around, linking the sample project in to the main model caused the node to fail…

Any luck trying this? Or even posting a journal and Dynamo log as is could help ID stuff.

Thanks for helping troubleshoot. I am going to have to debug and take a look on my end. Apologies for this. I would say to maybe try the node from spring nodes to select elements from links for now.

1 Like

No worries at all! I am just glad there are driving spirits like you out there helping the community! :slight_smile:

1 Like

Didn’t help, unfortunately.
I haven’t tried exporting the log, since I know there is a cumbersome process due to security reasons.
I did manage to handle the problem partly with the spring node :).

Logs and journals autogenerate, you just have to collect them and post them. Happy to take them via DM if the concern is public posting.

were you able to get it to work? or found an alternative? I am running into the same issue in Revit 2021 and 2022 but in 2023 the node works fine. thank you.


Unfortunately not.
If I remeber correct, I think I did get it to work decently with the spring node version.
But we changed the work-process and managed to work within the same model (not using links).

I have a new node for this in the latest version of Rhythm:

It does work with Dynamo player, but not with Generative Design though.

1 Like