Rhynamo - Rhino Geometry - empty list

Hi there,

I have Rhino geometry that i would like to import to Revit.
I’m using Revit 2018.3 and Dynamo 1.3.4. I’m getting empty lists for the rhino geometry. However, the other information embedded to the rhino elements is coming through such as layer names so the node appears to be working. My rhino geometry is built from extrusions and polysurfaces that have been unblocked. It’s relatively simple.

I have also tried with Revit 2019.2 and Dynamo 2.0 which results in the same.

I’m wondering if anyone has experienced the a similar type of issue. I have scanned through similar issues but the solutions seem to be related to the build. In my case the node appears to be working but not reading the geometry. Any suggestions would be great.
Thanks
column for dyn 2.3dm (473.7 KB)

Possible to share 3dm file?

Hi there,
The Rhino file (simplified) is attached above. I have also tried Rhino 5 and 6

Thanks,

I am having the same issue with Rhino 6, running Dynamo 1.3.4, and I have attempted the process with Rhynamo install 2018.11.26 as well as 2018.4.3. Both have returned “Empty List” with all “RhinoObject.Get_…Objects” commands.

I am a new forum user; therefore, I am unable to attach my Rhino file at the moment.

Thank you.

DynamoCanDo,

I’m assuming you figured out the issue by now, but if not, I realized my problem was the following:

All of my Rhino Objects were located on layers which were nested (or grouped) inside another layer. For instance, I tend to organize my layers by Curves, Surfaces & Breps (or Polysurfaces). I was attempting to translate the polysurfaces to Dynamo (and ultimately to Revit), but those layers were nested in a layer (or group) entitled “3D”. I moved all of my polysurface layers out of their nest and the objects were immediately recognized by Dynamo (Rhynamo). It appears Rhynamo does not recognize objects located on nested layers.

If this did not help you, I hope it will help someone out there having this problem.

Best,
:black_heart:

2 Likes