Rhynamo + Dynamo Problem - Missing Geometry


#1

I’m working through using the Rhynamo package to test out the rhino to revit workflow. I’m having a really strange hang-up right after I bring in the Rhino geometry where only portions of it are able to be read. In the Rhino file I’ve tried cleaning up the misbehaving elements and was able to get it to work for the most part. However, once I tried to move forward with manipulating the imported Rhino geometry, I had some other unexpected behaviors that made me revisit the Rhino file. Now if I manipulate an extrusion in Rhino, that extrusion cannot be read in dynamo. What am I missing? 2015_0904_Get Rhino Geometry Test_crw 2015_0904_Massing Study_Single Building_Test


#2

I’m trying another file now and I’m still missing the magic behind this package. I also tried Mantis Shrimp with no success and there seems to be a caveat to having usable Rhino geometry that I’m missing. Now I’m having a problem where stupid simple geometry in Rhino is not being shown in Dynamo using either package. The nodes are displaying items and the geometry is apparently generating something because navigating in the 3D background alludes to something being there, but nothing shows. Here’s a scenario: I want to import floor slabs that were created as extrusions in Rhino. The resultant geometry is displayed as a “closed extrusion” in Rhino. In other words, a closed polycurve was extruded and made solid in Rhino. This object cannot be displayed in dynamo using the rhynamo package for some reason. Does it have to be exploded? Does it have to be redrawn as a series of exploded curves? What’s the secret to being able to use any rhino geometry? The tutorials I’ve seen have been somewhat helpful in setting up the basic graph, but seem to fall short on real world applications like this issue with slabs. Has anyone had success with this that can share their experience?