Dynamo Geometry to Rhino


I’m trying to push dynamo-created geometry directly into a Rhino. I installed the Rhynamo package but have had difficulty on two fronts:

  1. The node to retrieve the Rhino file does not seem to recognize the input (I’ve also tried running the file-path through MantisShrimp node)
  2. Geometry is not being generated in the Rhino file

If anybody has had experience using this package or can recommend another package to achieve the same result, I’d really appreciate the help.

(I’m using Revit 2019, Dynamo 2.0, and Rhino 6)

I’m testing using a basic script to create a lofted surface between two curves:

Test Script.dyn (37.7 KB)

what does the error say?

1 Like

Warning messages show ‘Dereferencing a non-pointer’:

Warning test 2

I’ve tried copying all the files from desktop to my documents in case it was a problem with the file path, but no luck

so, I cannot be sure:

but from the committed files in this repo, it appears only the dylib for rhino 3dm read and write was committed… thats not to say thats whats actually in the package (or rather the proving ground installer)… but I don’t think .dylibs will load on windows.

Might be worth reaching out to Nate Miller.

I would first check you have the most updated version from proving ground as the package on the package manager is just a pointer to their installer.

Thanks Michael,

I managed to get administrator rights on my machine and re-install. This solved the ‘open rhino’ node which now gives correct outputs:

I am now trying different node combinations to get Dynamo to write geometry into Rhino, but getting stuck. Perhaps I will need to shoot a quick email off to Nate as you suggest. Will post solution here if i get one.