Dynamo not reading Rhino geometry


I am brand new to Dynamo and am trying to establish a workflow between Revit to Rhino using Rhynamo. I’ve been following a simple component string or file -> file from path-> OpenRhino -> GetDocumentObjects -> TranslateRhinoExtrusion. After completing this wire, I get a run error as follows:

“Warning: RhinoTranslationToDS.Rhino_ExtrusionToDS operation failed.
Method not found: ‘Autodesk.DesignScript.Geometry.PolyCurve Autodesk.DesignScript.Geometry.PolyCurve.ByJoinedCurves(System.Collections.Generic.IEnumerable`1<Autodesk.DesignScript.Geometry.Curve>)’”

I have downloaded the latest Dynamo and Dynamo Core builds:


I am using Revit 2019 but also have Revit 2015, 2017 2018 installed onto my computer. I’ve tried a work around I found on this forum that uses microsoft fixit to clear my computer of any Dynamo core files and reinstalled a fresh up to date version of Dynamo but I am still getting this error message. Any other options to try?


Whats your Rhino version?

Rhino 6. But I also have Rhino 5 installed on my computer

Don’t know where i read it but i remember that Rhino 5 is supported, not 6
some background info on

Could be messing with my head.
have you seen the Mantis-Shrimp package?

This version of Rhynamo looks like it won’t work with dynamo 2.x - I believe rhynamo is open source and can be recompiled for 2.x if you are able.

That solved it! I uninstalled 2.0.1 and installed 1.3 and it worked. Thanks!