Rhino to Revit via Spring Nodes Cut Pattern Problem

Hi all,

I am new to the forum, dynamo and revit. I am a student and primarily a rhino/grasshopper user. I have been interested in organizing an effective rhino to revit workflow where I can use rhino to model geometry and revit as a documentation tool. I have been using spring nodes via dynamo to import rhino geometry into revit somewhat effectively. However, I am getting inconsistent cut patterns from the geometry. Has anyone experienced this issue? Attached are two screen captures showing examples of the problem i am having. In the screen captures you can see a section box showing a proper earth cut pattern, then when the section box is moved the cut pattern disappears. This is occurring throughout the project as the graphics will show correct fill settings in certain sections but not in plan view(or other sections). The issue seems to be geometry specific as it only occurs within hyper-complex solids from rhino. I am only editing the objects by assigning them materials within object styles in an attempt to rapidly modify the geometry within all views. Any suggestions would be greatly appreciated.

In this link should be the revit file with the landscape in it. Would someone mind taking a look at the file to see if they are getting similar anomalies? Thanks!


Anybody have any ideas?

@thompsonburry According to you, there a problem in the image on the right?
I don’t see a problem.
You’ll need to outline your issue in a better way, if people are to understand and respond.

@Vikram_Subbaiah Thanks for your response.

In this image i have highlighted one of the solids i am having difficulty with. As you can see the solid does not have a cut pattern displayed. However it was treated with the same object styles as the earth poche below it.

The image below shows the same object from a different perspective. It is being rendered within the revit viewport as if it isn’t solid, you can literally see into the object.

The final attached image shows the same geometry within the same 3d view however in this image the section box was adjusted and pulled away slightly. As you can see the object is now being rendered within the viewport as a solid with proper cut plane assigned.

I have found this issue to be present with several of the geometries i am attempting to document within revit. I have attempted the same process with several other rhino models and have gotten the same results within one or two solids within each 3d model. I apologize to everyone if this is more of a revit problem than a dynamo one. I was hoping that because spring nodes is discussed in this forum that someone else may have run into this problem previously. Please let me know if further explanation is needed.

@thompsonburry The cut fill/hatch pattern is governed by the material in Revit.
For your geometry to have the same pattern as the base, you’ll need to assign the same material to your geometry as the base.

@Vikram_Subbaiah I am aware of how to edit cut fill/hatch pattern. I have assigned the same material to the geometry, it should be showing up as an earth fill consistently. And as you can see in the last image above sometimes when i move the section box the fill/hatch is displayed correctly, other times the cut displays no pattern at all.

Here is another example of the same issue with different geometry.

This is the geometry with a clipping plane in rhino showing where the cut pattern should be applied

And then here it is after being imported into revit

Here is the same object/view after moving the section box slightly

It is almost as if in some scenarios revit is reading the geometry with flipped normals despite them being solid objects.
I have tried all combinations of acis export options within rhino to see if i could diagnose the problem with no success so far.

Alright, I now see the issue, but won’t be able to offer any useful suggestions.
Somebody else might be able to. If not, try reporting the issue here

Have you tried simply rebuilding the geometry natively in Revit? While it may be easier in Rhino to create certain geometries I do hope you give Revit a shot because it can be very powerful if you put in the time and effort (especially once you get comfortable with Dynamo). In other words, try not to think of it as just a documentation tool. It’s capabale of far more and in fact more so than Rhino in the end. As an aside, this is probably one of the biggest workflow issues in professional practice right now and I hope that you work towards the skills that will serve you after you graduate. That’s my two-cents. Best of luck.

Hi Thompson,
I can’t see anything on the link which you have shared. Can you upload the files again. Thanks :slight_smile:


Hey, sorry the link wasn’t valid anymore. Try this one.


This is probably more of a Revit question than a Dynamo one.

Try using one of the ‘sectionable’ family types (I have used structural foundations) rather than generic families. I thought it did not matter in a 3D view, but maybe it does

Revit does struggle with the display of some geometry- particularly if it is imported- so I’d agree with Cody i.e model it in Revit. The topography tools in Revit are not great, but you should be capable of what you’ve shown in the earlier screenshots.
The easiest way to make what you have in Rhino is to extract the points (extractpt) from the meshes then create a topo from these points

@ Andrew_Hannell Thanks for your reply. I appreciate your input. I tried changing the imported geometry family but am getting the same results as previously encountered. I have a feeling this is simply not going to work the way I was hoping.
I agree with you and Cody that this would be best resolved modeling within revit, there are other geometries within the project that are experiencing the same issues. Some of them are custom complex elements that i don’t think could be modeled within revit, I could be wrong though.
Ultimately I’m interested in this workflow of getting a complex rhino file of solids out to a documentation tool, next attempt may be within Bently/Microstation, I think it can read rhino 3dm files natively.

I will look into the file a bit closer, but at first glance i think this might be one of those geometries that the Revit modeling engine just doesn’t understand. You can still get into Revit using the method you have but just with some extra creativity. To start with, try simplifying this particular form a bit and see what happens. Also do you know for a fact that this geometry is water tight and will form a solid in Revit?

the link still does not seem to work either…

Ok after looking a bit closer at the geometry in the screen shots (the link doesn’t work so i couldn’t anylize it further) I have been able to create geometry in dynamo or imported through dynamo that was completely valid, and was in fact impossible to create in revit manually… however, when trying to bring it in, i would get a corrupted geometry that was invalid in revit. after some research and asking around i have discovered that due to some significant difference in the revit modeling engine there are some geometries that are impossible to process in revit.

However, there are a few things you can do to get around this.

  1. you can try to import the base geometry and the cutting geometries and try to perform the solid/void operations in revit.

  2. try increasing the accuracy of the geometry by increasing the control points before you import it

3.there is still no guarantee that this will work so you may need to think of how to break your complex geometry into smaller / simpler pieces.

contrary to some previous comments i DO NOT think that it is worth while to create these manually in revit. I would be more than happy to discuss this further with anyone. I will also be teaching a class at AU this year on this topic and might be a good place to discuss this further.