Revit crashes when opening specific script

So, I’ve been working on a script to export excelfiles of window/door glass areas connected to specific rooms for quite a while now. Finally got the script working but when I reopened Revit+Dynamo I can no longer open that specific script. Revit and Dynamo just shuts down.

I’m using Dynamo and tried it with Revit 2017.2, 2018.3, 2019.1. Any Ideas?

Heres my script, if anyone manages to open it, please excuse the mess. Didn’t get a chance to clean it up :confused:Beräkningar - Dagsljus EJ KLAR.dyn (68.7 KB)

Sounds like the issue I’m having. When both Clockwork and archilab packages are installed on my machine, I can’t load scripts with Clockwork or archilab nodes inside them. Sure enough, I uninstalled Clockwork and could open your script, and I then uninstalled archilab and could open your script, but as soon as I installed them together at the same time, I opened your script and it crashed.

I just created a post about it here.
There’s also this post which is related, but I couldn’t get the solution to work for me.

Check if one of the package is not flagged for uninstall in your dynamosettings.xml.cfg file here C:\Users\Administrateur.000\AppData\Roaming\Dynamo\Dynamo Revit\2.0

Also if your packages are not located in two different locations (you could get the path in the same dynamosettings file). Dynamo does not handle well when you have some packages in the local appdata and some other in a specific folder.

you could try:

  1. Temporary manual removal of clockworks might work. and then try to open your script. if not possible:
  2. Temporary manual removal of clockworks might work.

that should help you narrow down the problem.

Thank you. I did a test and got the same results as you did. Sadly I’m in need of both packages so hopefully a fix will come soon. Following your thread in excitement, lol

I have a temporary work around if you need to run scripts. Hopefully it works for you:

  • Before opening Revit, manually move all packages out of your package directory to somewhere else.
  • Open Revit, and open a project.
  • Open Dynamo. Load a script that has nodes from packages. Those nodes will of course be broken and appear red.
  • Close Dynamo, but leave Revit open.
  • Move all your packages back into your package directory.
  • Open Dynamo again, and hopefully you can now open the scripts without a crash.

Kind of a pain, but at least I can run scripts when I have to.


Thanks. Guess that works for running scripts but I won’t be developing anything right now…

this workaround worked for me thank you.

Another workaround that I use successfully is this, instead of opening the script directly with Dynamo, open the Dynamo Player first. Navigate the browser until you find your script, then select it but don’t open it yet, click the “Edit in Dynamo” button, that will open the script without problems