Renumbering script fails on only my workstation

we have a script that we use to renumber our pipes for prefab. i can share both a sample of where we use it and the script.(i couldnt upload as a new user). the script works still for my coworker on his station and he can run it on my projects. im trying to learn dynamo but its slow going so this might be super obvious. the error occurs on the List.GetItemAtIndex node.
this script was built for us and there are custom nodes.

  1. Can you show us the graph?
    (Use the camera icon within Dynamo (top right corner) to capture it when zoomed in…) (And please use the “pin” icon to show previews under relevant nodes).

  2. Is there a difference in Dynamo/Revit version on you can your co-workers computer?
    If the graph is made for e.g. 1.3.3 and you’re running 2.0 it will need to be updated for the new syntax introduced with 2.0 :slight_smile: So please check dynamo versions on the two computers as well.

Let us know, cheers.

the reason i dont think its the syntax is it worked and stopped working within the same version of dynamo. i dont know if this is related but dynamo can only open files in 2018/2019 i can get it open in 2016/2017 but as soon as i try to open a file it crashes revit and dynamo.

sorry about the delayed response my account was placed on hold after posting this. (not sure why as its my only post so far?)

Which version of Dynamo are you on, and please zoom in on a node, enable all previews and then click the camera icon we cannot see what nodes you’re using :slight_smile:

this is where i think the break is for some reason its not gathering the lists?

Cannot say much from that… Show the entire graph, pin ALL previews and export an image where we can see information of ALL nodes using the camera icon…

Who provided the script? Also uploading samples to google drive or something would help

1 Like

it was Micheal with ArchSmarter.
here is a link to both a sample project we would run the script in and the script

here is the capture through dynamo with all nodes pinned let me know if this is what your asking

The problem looks to be that your searching for something like ‘‘NH cast iron’’ but your values are in fact ‘‘NH - cast iron’’… This results in empty lists making the graph fail…

this worked thanks!