Renaming system families with Dynamo


#1

Hi all,

Sorry if this has already been covered elsewhere - I have tried to find a post with the same problem we’re facing here but couldn’t. We’re using this script to try and rename our families so they’re Uniclass2015 compliant.

We’ve successfully changed names for most of the families including system families such as basic walls. But no joy when it came to wall sweeps. All elements appeared as “wall sweep” and after introducing element.name we could actually see the different names. Even the script seems to run till the end, there’s no success in actually changing the name of the elements.

Any help would be greatly appreciated!

Ignacio.


#2

Hi @icabrera,

Did you ever get clarification on this?
I am encountering the same issue. There seem to be lots of posts regarding loadable families, but when it comes to system families I get an error.


#3

You’re trying to set the name of the string, not the element.


#5

Hi @jaclyn.s no, unfortunately I didn’t get to solve this. There was this other post where it was attempted in a similar way but using Dynamo player with a more user friendly interface but it didn’t work for me either when it came to system families…

@Nick_Boyts I tried to give it a go with your suggestion but didn’t get far - sorry. In the original script the element.name node was placed inside the find/replace group rather than before the filter elements one. The problem I had with wall sweeps for example is that what I got in the list from there was wallsweep, wallsweep, wallsweep etc. not the name of the element itself. Not sure if that makes sense… Changing the node position got me slightly further down the line but didn’t work either…


#6

Can you show your updated graph?


#7

Hi @icabrera & @Nick_Boyts

The note about setting the element helps for loadable families - but system type / family is still inaccessible to modify?

Thanks for your help!