Rename Text Type that isn't Used

I’ve read another thread that matched my title, nearly. I assembled a graph that looks to have the necessary pieces but it doesn’t work. Can I get a shove in the right direction?

My goal: Rename existing but not used Text Type “Text Note 1” with “Notes, Dimensions - Transparent”

Rename Text Note 1.dyn (12.4 KB)

You need to use a FilterByBooleanMask node with an “==” node to match the strings. Then make sure you connect the All Elements Of Type to the Book node not the string output so you have an actual element to change.


Thanks for the shove…mysterious words you used :slight_smile: I’ll have to dig in more tonight when I get home. Thx.

1 Like

Well…it was a version issue. I used this graph in 2020 and it worked fine. I guess I’ll have to double the check the version running in 2018.

Rename Text Note 1.dyn (18.6 KB)

Revit Version: 2019
Dynamo Version: 1.3.4
Clockwork Version: 1.33.0

So I became a bit curious about this as well and I am finding that the clockwork node is failing to set the name of a TextNoteType element.

Technical info to follow:
In the clockwork node he is using a different method to iterate over lists involving def. If I try to do the same thing in a simple for loop it seems to work. :confused:

1 Like

Just for fun, I thought I would go ahead and test this in again with Dynamo 2.0.3.

Revit Version: 2019
Dynamo Version: 2.0.3
Clockwork Version: 2.1.2

And now it works!

setname.dyn (16.4 KB)

Technical info to follow:
I have a suspicion that something changed with the unwrapping in 1.3.x vs 2.0.x. :thinking:

1 Like

Thanks for the help. Glad to see it was not just me being clueless though that’s certainly part of the problem. Your example is simpler, cleaner and helps me grasp what Sean was telling me.

Edit: I might as well add that this kind of thing happens to me (maybe just me) every! time! I decide to dig into Dynamo. :frowning: