Rename Assemblies Issue

biggest noob on the forum is back with an new issue.
I have been trying to rename my newly created assemblies but i can’t make it work. I have been searching around and tried alot of different ways but i don’t understand how to do it with assemblies. Is it not possible to do with CreatAssembly as a basis?

SteamNodes has “Tool.RenameAssembly” node.

Hi @jakob.hansson for me it looks like you have invalid input in the node, try open the node and correct as here…and save, but not 100 sure :wink: thats the issue

I have noticed that one, however i did’t want to use it duo their warning. It works?

you could try set name from clockwork as well, for set type name

Yes it works.


Mine doesn’t, what am i missing?..

I tried this out, simple and good. It succes in Dynamo but it doesn’t change the name of my assemblie in revit??“sight”

It worked with “Select Model Element”. I dont understand it can’t work with “SelectInRevit”. Its basicly the same? Or is it becaouse SelectInRevit is for multiple elements?

I am not sure of the functionality of the “SelectInRevit” node, you may can try to place a transaction node between the that and the rename assembly node.

The rename assembly node works with a list also


1 Like