Project Refinery-Java Script error

Project Refinery is getting closed just after i opened,Just a Tab appears for 5-10 seconds and goes off.
And it is displaying Java Script Error.Kindly Help me out!Screenshot (68) Screenshot (69) Screenshot (70)

@Lilli_Smith @nate.peters - Any ideas on this one?

@charan1644 You can only have one instance of Refinery open at a time. You’re seeing this error because the second instance is trying to communicate with Revit or Dynamo on the same port that the first is using. If you upgrade to Revit 2021, the latest version of Refinery (now called Generative Design) will handle this error and explain the issue.

If you don’t actually have more than one copy of Refinery open, check your task manager and make sure that you don’t have any system processes named “Refinery.exe” or “GenerativeDesign.exe” that are hanging around after the app is closed. Restarting your computer will take care of this as well.

2 Likes

Thanks for your reply!yeah,That JavaScript error displayed few times only when I eventually had to go to the file location of refinery and tried opening refinery through that.But I did so because the refinery is not opening and it’s tab open for few seconds and goes off as you can see in the last image.I tried reinstalling but didn’t work.what do you say?