Problems with Dynamo for Revit 2020


I’m having a lot of issues with Dynamo on Revit 2020.

I was on R2020.2.2 and experienced these problems - have updated to 2020.2.3 and have the same problem. I believe things were fine with earlier builds, but wasn’t doing a lot of Dynamo at the time.
Revit 2019 and Dynamo 2.0.4 works fine.

Essentially Dynamo opens fine, but after a little while, or if I run a graph, just starts graphically glitching.
Varying degrees of not being able to select menus and nodes, run graphs, search for nodes etc.
If I close Dynamo and re-open I get the following error:


Restarting Revit allows me to access Dynamo, only to have the same issues within minutes.

I have tried:

  • Updating Revit build as mentioned above
  • Cleaning out appdata files
  • Removing all packages
  • Starting with a clean graph.

Anyone with any ideas how to resolve? I guess I am staring down the barrel of a full Revit 2020 re-install, but would prefer to avoid it if I can.

Try disabling all Revit add-ins as a next step. A conflict there would explain your not having issues prior to 2020 and could produce some of this behavior.

You could also check the Dynamo logs for errors, and the Revit journals for API errors which would confirm some of these issues.