Possible to force open a file which says it corrupted

I have a simple Dynamo script with some color overrides in Python and reading an excel file. This has been working fine, but today I tried to open it and it gave me this Error. The file will not allow me to open the file. Can I force open the file. How would someone salvage a flow if the file is locked?

This has started to happen when I started using 2.0
This the message which only allows me to click ok.
Error

Can you post your file?

Here is one of the files I can’t open.
KR - COLOR.dyn (163.0 KB)

@Danny_Bentley the file isn’t corrupt, someone upgraded it to 2.0.

Run it in 2.0 going forward or check the backup folder for a 1.3 version (though it says you wrote it in 1.1 so maybe the 1.1 version).

Sadly it will not open in 2.0 or 1.3. I don’t have 1.1 installed. There must be a way to open it. I understand if some of it is deprecated, or corrupted but should allow us to salvage the flow and python to move into a clean .dyn file.

I managed to get it open doing the following:

  1. Open the file in a text editor
  2. Change line 3 value to true. "IsCustomNode": true, save and close
  3. Change the file extension to DYF
  4. Drag into Dynamo 2.0

It seems that there was some weird error regarding notes with the same GUIDs.

I removed all the notes and here is the graph:
KR - COLOR-fixed.dyn (160.3 KB)

6 Likes

John, I could give you a big hug right about now. Thank you for the help. It worked!

1 Like

Glad to help out man!

1 Like