PolyCurves may be branching

Hi

Im using Dynamo to calculate the excavation masses in projects.
In the start of that script i import the Toposurface, and transfer it to a Mesh, and then to Polysurface. which i use further in the script.

Used this on pretty big and detailed scanned surfaces without any problems before. Now i get this Error when transforming a Toposurface to Mesh:

image
Seems to appeared after 2020 upgrade of Revit, with integrated Dynamo. as i have used the exact same topo to do this work before.

Tested many things and workarounds without luck.

  • Geometry scaling is at Large, changing it wont fix it.
  • Tried recreating the topo from points in Dynamo, ending with the same error
  • Tried Mesh reducer, aint working.
  • Tried various scripts that other with similar problem have used in this forum, also without any luck

Anyone else encountered this and solved it? Appreciate all advices.
(The Forum wont let me upload any files (new user))

post a screenshot of your graph (use the camera button so that it is legible)

Camera inside Dynamo only reports 0Kb files, hope this helps.

Topo: (reduced it from 4000 to 1000 points, still not working)

@Tore,

can you share files with curves somewere and post link?
We’ll try to help.

Cleansed and purged rvt file with topo:
Topo.rvt (2.6 MB)

Try this:

Topo2.dyn (22.4 KB) I

Thanks alot Vladimir

Just by adding code blocks with 1 og 8 connected to the Node Springs.Mesh.ToPolySurface seems to be solving the problem. The error in Topography.Mesh gets ignored.

What Function does those numbers do?

Hi, @Tore!

mergeAll is the boolean input. 1 is true, 0 is false. mergeAll makes one big surface from triangles, which topography consists of. (It seems, that your topography wasn’t merged by default, i’ve checked it in 3ds max). Maybe some “merge” option was turned off in topography application this time?

NUMTHREADS is the number of logical threads of your CPU. It’s the first and last node)), which takes all the power from your CPU. It ~x times faster, if you’ll choose 1 or X.

ah, i see.

Thanks again for quick response and solution Vladimir.

Much appreciated.

I noticed the updated package does not have this input in the node, it does not work in complicated topography, revit closes automatically