Topography.IntersectionWithPlane

This has worked in the past, not sure what its deal is now. Any help is appreciated :slight_smile:

image

Looks like it’s the Topography.IntersectionWithPlane node which is causing the error, not the Polycurve.Curves node. What package is that from?

1 Like

its from clockwork, im wondering if theres an alternative method to do the same thing. Something more reliable or stable. I think maybe the complication of the topo makes it crap out some times, but im just guessing.

Hi @vanman

It may be that the intersection points attained by the node are being sorted into an order that initiates the “Polycurve Curves my not be branching” error (I have dissected the node and its functions, and this appears to be the case) Can you post a screen capture of the topography? and where the intersect plan occurs?

The below capture indicates the sorting for the polycurve intersection is more complex than it need be…
(This is the insides of the Mesh.Intersection with Plane node)
image

Hi Ewan,

Will do my best to respond to what your saying, sorry if theres some confusion

The topography doesn’t show up in Dynamo as it usually would after running the script. below is what it looks like in revit. No matter where i cut a section or elevation in it the node wont work as it usually would. It does run for a long time before getting the error though

Have you modified the Mesh.Intersection with Plane node and i should change it and give it a go your way? My node looks like this when you go into it from the package.

I extracted the nodes from within into a blank DYN, to determine where any error was occuring.
Can you post your current DYN and a stripped version of the file?

1 Like

I see, smart. I was wondering if dynamo had some sort of live progress function you could watch with.

Here is the dyn and revit file with topo.

Topography.rvt (2.3 MB)
Existing Ground Lines_For Current View.dyn (10.3 KB)

When the DYN is executed in a Section view (that cuts the topography) it does find points along the surface, it just cannot create the Polycurve because of the “branching” effect of the point order being jumbled. This could be due to the roughness of the surface.

You can work around this by using the extracted points the node does find, cleaning them and sorting them along a vector, before constructing a Polycurve. Worked for me, hope it does for you :+1:

Awesome! what package is the node “sort points by average vector” from?

The Sastrugi Package :wink:

Still getting Null values with the intersection with topography node :confused:

image

What happens if you remove the List.FirstItem node that is after the Pick node?
Also where is your section taken in relation to the topography? Can you show a plan view?
(I am not sure the file you uploaded contained the same section you display in your examples, but correct me if im wrong)

Same deal without that node. Sorry you are correct I just opened a new file and copied the topo through to make it small enough to upload here. Topo in the original purged file is Below. The section view I just tried is “Section A1” under group “A Building Consent”. All the sections and elevations dont seem to work though for me

Thanks for the new file, will try it in the morning :+1:

1 Like

I have run the DYN with the exact same inputs and have this result.

A few things to try.

Does adjusting your view depth to be say 100mm make any difference?

Update Clockwork? What version of Clockwork do you have installed?
I’m running 1.31.0 at the moment.

Try this DYN which I have extracted the node contents out of Topography.IntersectionWithPlane.
It displays that there could be some lacing issues and null values stopping the creation of the Polycurve.
(This has, with some tweaks, created a polycurve on the topography, as seen in the background preview)
Existing Ground Lines_For Current View TWEAK.dyn (47.4 KB)

Apart from trying the above, I may be at a loss with this one @vanman :thinking:

Or here is an alternative workflow using the MeshToolkit package.

Hi Ewan, thanks for all the help and replies so far! So…

Adjusting view depth made no difference.
I’m running clockwork 1.0.3 (will update this and try again)

I was using your tweaked version but one of the nodes you created appears to be broken. Not sure how to type an input with a hyperlinked input after. I say hyperlink but I don’t know the terminology for it with dynamo or programming

Tried the alternative method you kindly created but that unfortunately errors my revit and closes it

Geometry working range maybe?

So this worked! Just skipped the node i was unsure about. I’m going to go back and try some of your other suggestions with updated clockwork

1 Like

I’m trying to use your solution across multiple views. Think I’m close but cant get it right with the lacing i think. It drew lines across 3 views but only the 3rd view had the lines in the correct place. The things I have done to modify so far are below.

I by passed the plane node because it didn’t list multiple plans and i changed geometry.intersect from cross product to longest lacing. I’m not sure if that was an error to do but it got it drawing lines across multiple views.


I changed the lacing on the DetailLine.FromCurve to longest as well

Any suggestions to get it drawing the lines correct across any amount of selected views? :slight_smile:

Existing Ground Lines_For Selected Views_Test.dyn (73.2 KB)

an update… it dosnt seem to like having selected views on different planes. Something I’m probably missing earlier on in the script. The first two views are on the same plane and it gives nulls. The other two are on another plane and it puts threw the values. Probably isn’t even related but thought id try give it a go