Polycurve workflow issue

geometry
revit
dynamo
dynamostudio

#1

Hi there,

I have been working on a code that works with some curves, joining them into polycurves and working with these polycurves afterwards. This workflow was fully working on DynamoStudio, but when I try to do the exact same thing in Dynamo SandBox or Dynamo/Revit I am finding the following issue:

  • Polycurve is joined correctly with no errors, but when I want to reverse that polycurve or find the closest point from the polycurve to a point, the program deprecates all the curves composing the polycurve but one.

  • I have tried using other nodes, such as Nurbs but (of course) the curve I get is not the original one I had

  • I have also tried converting the original nurbs curves into lines, but that doesn’t make any change to the final result.

  • I have also tried modifying the lacings, levels,… But that is not the case either

I will be really grateful if anyone can give me some light on this.


#2

Please share the dyn needed to reproduce the issue.

Note that there are three segments in the first curve as it was fed three lines.


#3

Hi @aperez_SACO

Try doing Curve.Reverse before Polycurve.ByJoinedCurves.


#4

This works for the reverse operation but is no longer useful for example for Geometry.DistanceTo or Geometry.ClosestPointTo


#5

I can’t really share the file, sorry. Yes, the three segments that compose the polycurve are the ones that I have joined to create it. Usually in Dynamo Studio there is no issue with that, but in this case I really don’t understand why, whenever I try to work with those polylines it deprecates part of it


#6

Personally, I can’t really help without seeing how you got here. I had a few thoughts as to ‘why’ it’s happening (inline points, geometry working ranges), but none of them panned out in my examples. Since I can’t recreate the issue I’m unable to help. :frowning:

Removing all but one of the failing polylines from the file should remove any concerns you have with sharing, and should allow us to see where the issue is.