Polycurve from corridor featureline

Hi All,

I am trying to get the auto corridor featureline geometry to Dynamo polycurve but geomtry nodes are returning null value.

anyway around or am i missing on any node ?

Even tried with removing Dynamic link to featureline and still cant get the polycurve representation of featureline.

if i create a featureline from polyline and then created polycurve, it worked.

(Kindly note i am having a corridor created on dynamic fatureline so cant use corridor featureline nodes.)
Thanks for the support.

Hi @shahid.shaikh_C3D, I believe you will find solution here in dataset from this online AU presentation
Supercharge Your Dynamo Graph with Civil 3D Toolkit

Hi @Drbohlav, thanks alot for the reply and i have gone though the class but sorry didnt find the solution. Please let me know if you find any.

Actually its a limitation of dynamo that it cant get corridor baseline if its created using featureline. That being know what i did is tried creating a dynamic featureline/ without dynamic link also but could not get the polycurve of corridor featureline even if its link is broken with corridor. At the same time i was able to get the geometry of featureline created from polyline.

Currently i can think of only one solution, explode the featureline and get a 3D polyline out of it. then we can get polycurve of 3D polyline i guess.

Correct @shahid.shaikh_C3D, I meant that there is no Civil 3D API that catches the Alignment Id when the baseline is derived from a feature line, which is necessary to create the Baseline object for the Dynamo Feature Lines. Coming in the new Civil 3D Toolkit


Thanks alot Paolo…Toolkit always have solutions, i really appreciate all your work and efforts.

Thanks again.

Hi @Paolo_Emilio_Serra1.
I only get the featurelines from the corridors which are created with an allignment.
Do you know where i maybe have made something wrong?

Corridors with Feature Lines as baselines are not supported in Dynamo.

But Paolo posted a screenshot 2 posts before mine.

@genossealex can you please attach the Civil 3D Toolkit log file?

@Paolo_Emilio_Serra1 here is the log file.
Autodesk_Civil3DToolkit.txt (1.1 KB)

@Paolo_Emilio_Serra1 could you find the problem?