Problem to create a feature line from polycurve

Hello everyone!, I have a problem to create a feature line from polycurve with "Featureline.ByPolycurve node (Civil3DToolkit 1.1.14). Briefly if I use the coordinates from un external file or captured Its from a geometry the node create an polyline 3D, instead if I create the points inside Dynamo with code block the node create a feature line. One thing curiosity is this, if I use the Z coordinate unique for all points the node create the feature line but if I use a list the object come back as polyline 3D. thank for any suggestion to resolve this problem.

Hi Santi can you share the Polyline 3D? Also can you share the log file? it is in your temp folder and it contains Toolkit in the name

Hi Paolo,

Thanks for your help, in attachment the log file requested and a small video where you can see what happen.

(Attachment Autodesk_Civil3DToolkit.log is missing)

(Attachment 2020-11-21 01-04-25.zip is missing)

Thanks for your help, in attachment the log file requested and a small video where you can see what happen.

Sorry I don’t know why the attachments was rejected through the e-mail, I send these directly from the forum.

Autodesk_Civil3DToolkit.log.txt (3.9 KB)

This is not the latest version of the Toolkit, but I saw the problem in the log. Nothing wrong on your side, there is a restriction in the Toolkit (by mistake), you will have to wait the next release.

Hi Paolo, Thanks for your help. I will wait the next release.

Hi at All, if someone is interested I solved this inconvenience with this workaround. Create a feature line between the first to last point of te sequence, after we can use the node that permit to insert the others point inside the feature line (FeatureLine.insertPIPoint).

2 Likes