Point Cloud parameters

Hi everyone,

Everytime I try to import a point cloud to Dynamo, it is imported as a single element. Is there any way to import to Dynamo the points of a point cloud as separated elements? Capture

Hey, try this maybe?

Cheers,

Mark

It didn’t work for me. It results in a warning saying this: One or more types of input aren’t coincident. It was not possible to localize a version of __func_bb7beb8577ab44629a8b4e08c055dac0 that gets arguments of the type (Revit.Elements.Element)

Hey,

If you double check the examples given in the link you’ll see that particular node takes different inputs than you are feeding?

Hope that helps,

Mark

@Mark.Ackerley is correct as the node input PointSampleSize expects an integer, as this is the number of points that will be collected when using the node.

Here is the link to examples again for reference:
https://sites.google.com/view/sastrugi/examples

I tried to do such as the example of the link you shared, but it didn’t work. Am I doing something wrong?
The screen video of what I did: https://drive.google.com/file/d/1aPH3O36IvIEV_QMbcUPmvgKBKNM3s7cq/view?usp=sharing

The selection box prompt shows a requirement to select from the bottom left to the top right, you have shown a bottom right to top left selection.

Can you attempt this using the instruction from the prompt and let me know if you are still experiencing the issue?

It still occuring, @Ewan_Opie. Look: https://drive.google.com/file/d/18JPmSR5IeJLTxyJEjrFeIAUWbOeVSgzc/view?usp=sharing

I have an idea to test. In your 3d view can you turn on the section box,the try again? You don’t need to reduce the size of the box, just toggle it on.

One of the filtering functions may be to be here and if we can figure out which one I should be able to provide a solution.

It didn’t work again: https://drive.google.com/file/d/12-0RIpAxZdNq7pyX-ik5Tmnl6QuA5NGh/view?usp=sharing

What version of the package are you using?
Can you update to v 0.1.5 (current release) and test again?
Really want to have this sorted for you :slightly_smiling_face:

@lucas_20
I have found the issue, :man_facepalming: a Boolean toggle was preventing the data from outputting.
Please try this modified version of the updated node from v0.1.5:

__Pointcloud Select Points in View.dyf (70.1 KB)
(Copy and paste this over the existing version in the Sastrugi package path folder)

I will include the updated version of this node with my package upgrade to Dynamo 2.0, but in the meantime, make a note of this node update on the topic here Sastrugi Package - Updated, as well as on my website.

Thank-you for bringing this to my attention :+1:

1 Like

Just a random question on your tool sets. I tried a couple of your examples on a Matterport file brought in using Recap pro and I can’t get any of the tools to recognize any of the points. Is this something that anyone else is experiencing?

Thanks in advance

Example 1 _Pointcloud Set Graphics Override for Scans - Visualizing Scan Locations

Example 2 _Pointcloud RANSAC Plane Detection - Extracting Wall and Floor Points

Havent had that before…
Can you post a link to a sample of your data?
Then I can take a look :slight_smile:

here is a link to a matterpak file the file will need to be converted from Recap pro then linked into revit.

You can download at:

https://documentcloud.adobe.com/link/track?uri=urn%3Aaaid%3Ascds%3AUS%3Af2b87ba1-4a85-4cbc-aa1b-37159daf8e50

Did you get the chance to look into the matterport file?
Thanks in advance

Hi @jarod.tulanowski
Sorry I have been really busy with projects.
I had a quick look and was able to bring the file through Recap to Revit and select points using the nodes.
Perhaps try using and refreshing the shape of the 3D section box / view perspective between attempting to pick points?