Place Adaptive Component by Points

I’m attempting to place a 3-point adaptive component by points. This sounds and looks incredibly easy but i’m stumped as to why it’s not working:

Note: The three points are at different X, Y and Z coordinates.

Any help much appreciated

Hi @Andy_Grout,

The AdaptiveComponent.ByPoints node expects a list of list(s).

So if you run your list of XYZ’s through a List.Create is should place the AC.

1 Like

Hi Martin, thank you for the suggestion. I’ve tried this method and it results in same warning:


3 Point AC Placement.rvt (700 KB)
Place 3 Point Panels.dyn (43.5 KB)

Try by adding list create node again as shown below


the concept is this node accepts only the list of points image

1 Like

That worked! Wow, this node is very particular

Thank you!

I have a 60 point adaptive component, however, l have a list of points, however, it states “the arguments have issues”. Any thoughts?

It is just for a representation of a wall.

Here is the result.

Points present, appear in order, yet nothing placed within model.

Can’t see much of what’s going on as you haven’t shown the drop-down data from previous nodes.

However try to add a ’Flatten’ node between ’Point.byCoordinates’ and ’List.Create’

Many thanks for replying Andy.

I have just expanded the nodes…

Flatten appeared not to do anything…

Andy, below is what l am trying to place. 60 point adaptive component placed by XYZs

The issue may be due to an incorrect ordering of the points you’re feeding in.

What method are you using to ensure the points are ordered in the same way have set them in the adaptive family?

Best to check what order your points are coming out in dynamo

I did think this close of play yesterday.

I shall look into it.

The order of the 60 points match the desired order of the adaptive component, therefore, it should work, however, the A.C. is not playing ball.

I have tried l feel all combinations of ‘lacing’, yet no joy with the component.

I have attempted a whole variety of node connection and lacing options and combinations, yet no joy.

Hi there, I believe the problem may reside in the adaptive component family itself. I’ve previously encountered issues with adaptive components being inflexible to adopt shapes more complex or larger than the original form made is the family editor.

I therefore suggest trouble-shooting this by making your adaptive family with the points at same coordinates as you intend them to occupy in the project file (it will at least tell us if the issue is as suspected).

You can set the points in family editor using the following process:

Then, after the family is loaded into your project, you can now try to place adaptive family via dynamo as before:


Hopefully by making the adaptive component at the same scale/shape as you intend in the project, the geometry won’t ‘break’ when trying to place.

Script used here: Adaptive Component By Points.dyn (91.7 KB)

Test project file here: Test Project.rvt (636 KB)

I’ll try that.

I feel it is the extreme in alteration upon project adaptation that is causing the issue and not the graph or workflow.