Parameter.SetValue not working (no error)

I’m trying to set a parameters value after it is created in a family. The idea is to add a bunch of shared parameters to the family and then set the value of the type mark. The script adds the parameters but does not change the value of the Com_Mark parameter.

Maybe try passing the Document output of the Parameter.AddSharedParameter node to the input of the Parameter.SetValue node? What may be happening is that the Parameter.SetValue node might still be referencing the active document prior to adding the shared parameter.

Still not working.

I’ve also tried re-attaching the default node to the familyType input. still nothing.

The node notes that the family needs a default type. Don’t families always have a default type, even if they only have one type? I’m currently using a empty family to test this, but I’ve ran it with another family with several types and still have not gotten the parameter value to work. Here is what my blank family looks like.

Hello crapai

I think your problem is in the “familyType”.

  • There must be some Type
  • The Types and the Value have to be grouped in the same number of lists (and this is important).
  • You can not leave that field empty

a greeting

I’m sorry it’s repeated.
I’m a noob

Thanks for the input. I’ve created this and it did set all my marks to RP.

1 Like

I’m glad I could help you

When a Family without Types is inserted in Revit, it automatically creates a Type.
Maybe it does not make much sense to insist. There must be at least one Type in the Family. Revit works like this.
I think
a greeting

1 Like

On a related note I’m trying to set a value now and it is only using the first index in the list. The section below is setting each type to 20-08.

Thanks, Now that I know how the original node works I’ve found it very useful for converting families to our new standards. I don’t know if I’d actually use the new one but I’m sure someone will at some point.

Yes effectively. If we insert a Family in Revit that has no Types, create one with the same name as the Family.
I think we can agree that this is due to a bad workflow or forgetfulness. Insert a Family without Types … umm. But if possible.
I understand your considerations about finding a solution when the Type is blank.
Put a value on a Type that does not exist yet … exciting :slight_smile:
a greeting

Thanks, erfajo for develping these nodes and helping people like me wandering through the dark blindly.

I’ve figured out why it was only sending one value to the family types. I needed to mess around with my level settings.

aha! Eureka! Thanks. Theres just one more part left which is setting the created bars to the same parameter spacing and number to the original. I put this in so long

tried this doesnt seem to work