Package Bumblebee: name 'os' is not defined

I’m using bumblebee 2016.9.3 in combination with Dynamo and I get an error ‘name ‘os’ is not defined’ using the node ‘write excel’ and ‘bb data’. Any idea what’s wrong in my script?sheet to excel_test.dyn (6.2 KB)

1 Like

Do you have a file at C:\Program Files (x86)\IronPython 2.7\Lib ?

Try this version:


I’m getting this same issue in Dynamo, Bumblebee version 2017.11.2 (I just updated). Should I now downgrade to fix this?

actually, you want to upgrade. I have been pushing some small fixes recently. Try the latest.

I am using 2017.11.2. Is there a newer version than that which won’t have this problem?

I think you might be on the latest version of Bumblebee. That should be fine.

I’m still getting that error though…
Here’s a screenshot of what I’m seeing and the all the Dynamo packages I have:

you have other versions of Dynamo installed?

I had a similar problem with bumblee package. Version 1.1.0 dynamo, revit 2015 bumblee version 2.11.2017. It’s like this:

Getting the same error message as others. I’ve tried latest 2017 and latest 2016 bumblebee installs. Running in Revit 2016.

I would check the version of python that is installed and the install location, as @Einar_Raknes suggested - where is bumblebee searching for python libs?

Worked like a charm after appending inside the phyton scrypt:

import os

before line 18:

from os import path

All the best.



Could you show me what is the phyton scrypt to modify? I have the same problem when I write to excel :frowning:

Assuming that you know how to edit a custom node and a phyton script, here is the screenshot for the bit that must be added to the phyton script inside the BB “Write Excel” custom node (you only have to add the selected blue line):

If you don’t know how to edit a phyton script inside a custom node, please take some online videos like this one:

Please let me know how it worked for you. I could further assist with that.

All the best,
Lorenzo NEY



Finally, It’s working like a charm. I don’t know how to express my thanks. I had spent a lot of time for this problem.
Thank you so much :heart_decoration:

Hi @Kha_Le

Next time please create a new thread and link the topic which is similar to your issue. Thanks :slight_smile: