Old data stays in Excel list when data is removed from Revit

Hello People,

When i use the node “Write Excel” from Bumblebee, the following problem occurs:

  1. The data is well written from Revit to Excel :+1:t3: (see figure1)

  2. But when i delete ‘12.1’ from Revit, and I run Dynamo again, then the list is no longer OK (see picture2)

  3. I would like to see the list without the old data (Figure 3)

Is there a way to get it?

When you delete the data, the next row gets bumped up to the first row so the node always write from A1 in excel.
Try to insert a null item or see if the bumblebee node can start from NOT A1 cell when writing

Or clear the contents of the excel spreadsheet prior to writing. Or write to a new sheet by changing the sheet name to include a date/time string.

That’s a good one!
Do you have any idea how to do this, or do you maybe have an example ?

That’s not an option for me, because every time the data changes in Revit, a new Exelsheet will be created?


thats correct, but what do you mean with: NOT writing from A1?
if i start writing from another cell, The same problem occurs?

Try the built in excel.writetofile node which has a value ‘overwrite’ which I believe will remove all data each time it writes. You will lose formatting though as a result. If that doesn’t work you could write twice - once with a very large set of empty strings.

Yes, but in a new sheet not a new file. You can have a printing view in the same file and change the reference to the new data each time you run the script. This way you won’t have to reformat or change much, and can always go back if the design reverses to a previous point. Only takes just some references which can be updated in excel with like 5 seconds to change if you know how to do it.

I have already tried that. Indeed, the data is completely replaced. That’s good, But when the data changes in Revit and the script is re-running, then there’s another problem:

I want to link those cells into another sheet (same file) (template) then the cells are no longer recognized. (see picture)


Instead of, ‘sheet1’, there will be #VERW, so the data is gone :confused:

I have no idea how to make that happen.
Is there a way to do this in the same dynamo file, so I can only run the entire script 1 time?
And how do I give priority to first running the empty list?

Thank you in advanced for all the answers!