Noob Question . . . Dynamo is not connected to Revit

I have started Dynamo from Revit 2017 and created a 3 node script that starts with Selected Elements. When I select things in revit, Dynamo indicates that nothing is selected. I don’t see any way to select and instance of Revit to connect to . . . what am I missing?

Dynamo Revit, Revit 2017.2

Hi :slight_smile:

Have you clicked on “Select” in Dynamo, then clicked on something in Revit ?
Because the node is working fine for me :slight_smile:

When I click on the select in the dynamo node my Revit window loses focus. Then I select something in Revit and the Dynamo window loses focus. Then I can click something in Revit, and the Dynamo window does not update to show something selected. I have been looking at the tutorial, and selecting things in Revit automatically updates in the Dynamo window. I’d really like to see the list of elements selected before I hit the run button.

Do you have multiple instances of Revit running?

Just one instance. The model open is on the cloud though. The Revit icon in the task bar shows 2 windows when I hover over it, the Revit main window and the Dynamo window.

In your explanation, we should confirm that in the bottom left hand corner you have “Automatic” set instead of “Manual”.

When “Automatic” is selected, move Dynamo to a second monitor on your computer. If you do not have a second monitor, then split your one monitor to have Revit on one side and Dynamo on the other. Then click on the Select button. The Revit command should fire at this point.

Ok, I switched back to Automatic. I already have the windows on separate monitors. So I have tried a couple of things:

First, I select a series of lines in Revit. Then in the dynamo window I hit the select button (in the node I have pinned the results pane so that it always shows). The select node simply shows null.

Second, I hit the select button in the node and then click in the revit window. This only activates the revit winodw, and with my second click I select a wall. The select node in Dynamo shows as null the entire time.

Where are you clicking ? If you are clicking in the canvas, the observed behaviour is normal. Have you tried Alt+Tab ?

Thanks both of you for your time . . . mellouze I have tried that as well:

When I hit Alt+Tab to activate the Revit model window the Select mode from Dynamo stays active (seems good). Then as I move my mouse around the Revit window the ribbon windows respond (highlighting as the mouse moves over) but no model elements react to the mouse. If I click in the canvas then the revit model elements will start to react to the mouse movement, but the Dynamo select mode turns off. How do I get the Revit model elements to show in the Dynamo “Grid” that’s in back of the nodes?

Link to video showing the issue?

There is a difference between “Select Model Element” and “Select Model Elements”. The latter expects a crossing window or multiple elements in some fashion.

1 Like

Good catch there !

Ok, I think that I’ve been wanting the node to get the current selection set (something that I rely on when creating regular add ins), and now understand that they are asking for a selection (which I still can’t get to work but will try a few other things). I’ve modified and plugged in the Element Types connected to the All Elements of Type, and this created automatically a ton of area boundary lines that I can’t select or delete. So I’m switching back to manual after a close without saving. But at least I know that Dynamo is working with Revit as expected!

If you couldn’t select them they were probably the geometry preview of something.

By the sounds of this thread you’ve jumped in a bit quick and missed some of the basics - Dynamo does some stuff differently than you might think based on your development experience. I suggest ive the Dynamo Primer a read when you get a moment.