Nodes Disappeared

this is the error i get- Dynamo.Exceptions.LibraryLoadFailedException: Failed to load library: BuiltIn-

if i open it in dynamo 4 revit the nodes are gone if i open it in standalone the nodes are there but errored out. since it only appears to be the built in nodes and not my package nodes and due to the error i think something happened to the default library. you can see both screen shots are the same file just one is opened in sandbox/standalone/core and the other (with fewer nodes and no errors) is in dynamo 4 revit

I am having this same issue. I’ve tried to update my packages but I feel like it’s not getting me very far when the packages have dependencies… one package is unloading an old dependency while the other installs it and then it doesn’t load properly.

Hello @BlakeBunn - Are you able to please provide a screenshot of the ‘Show Details’ on your notification window?

i guess i dont know where the notification window is in dynamo? i looked at all the settings and couldnt find anything on this.

In your screenshot on the top post, it’s that pop-up window :slight_smile:

You can access it by clicking on the grey exclamation mark (!), which will also have the green icon next to it if you have any pending notifications.

image

When you Display All Notifications you will have the option to check the Show Details button which will output a bunch of data as shown below. This will help us get to the crux of the issue.

image

both notification options are grayed out in stand alone and the revit addinnotification

Would you be able to do this in Dynamo for Revit? Basically, can you re-create your original screenshot :slight_smile: ?

yeah here are the new screenshot

And in this, are there any Notifications that you can expand using the Show Details link, as I showed in my screenshot?

no still greyed out?

Ah… I see.

@Michael_Kirschner2 @Qilong_Tang - If a notification has been suppressed, is there a way to retrive it? i.e log files?

the log will be useful, the version of Dynamo revit etc - Definitely we need to know what addins you have installed in Revit and if you have tried disabling all of them and reproducing the problem.

logs should be in %appData%/Dynamo/Dynamo Revit/ version.

1 Like

dynamoLog_1d65421c-2fc5-4472-ab73-5e89474593cf.txt (4.9 KB) dynamoLog_3b01dc21-be52-45f7-8c5f-137f031ee500.txt (4.9 KB) dynamoLog_1c00d03a-ac02-4ec9-a5c4-84fbb553051f.txt (48.5 KB)

these are the most recent ones

did the logs clear anything up or was there no clear solution on this?

is there a better place to get support on this? its pretty inconvenient to not have dynamo and its been 2 weeks.

Hello @BlakeBunn,

Looking at the log, there is a load failure with the Library.

2020-04-30 16:05:04Z : Failed to load library: BuiltIn
2020-04-30 16:05:04Z : notification:Dynamo.Exceptions.LibraryLoadFailedException: Failed to load 
library: BuiltIn:
Failed to load library: BuiltIn: 
Invalid library format.

Have you tried what @Michael_Kirschner2 suggested (Quoted above)? Usually when these kind of errors occur there is a dependency conflict with a Revit Addin.

yeah i tried that and i tried redownloading it i even did a complete reinstall of revit

what version of revit are you installing?

when you opened in sandbox did you use 7zip to unzip it or unblock it before unzipping?

how did you uninstall all packages and addins?

Have you tried it on a new machine? I’m not 100% that uninstalling revit necessarily uninstalls all the addins. This is just a good step to isolate problems (vm would work as well)

do you see the same builtin warnings in Revit? Or you just see the missing nodes?
I see you have pyRevit installed - if so please make sure to update to the latest version of that.

1 Like

2020 and 2019

yes

through packages-search for packages

no but they all work and come up with all nodes on my coworkers machine. i can rebuild and use it but when i reopen it the nodes are gone

the nodes are just missing in the revit dynamo they show up with errors in sandbox and not at all in revit.