Dynamo Strange Problem

Hi
I am using Dynamo 2.02 with Rvt 2018 I have downloaded Archi-Lab package I seem to be losing the nodes display.
I have uninstalled Archi-lab package this goes away re-install creates the same problem.

I am attaching a screnn clip which also lists other packages installed?

Has anyone seen a similar problem and possibly a solution?

Thanks.

P.S. I n addition it also crashes Revit as well without an error message

This appears to be due to a missing Revit update. Can you check which version of 2018 you are on? Should be 2018.3.3 per this article: https://knowledge.autodesk.com/support/revit-products/downloads/caas/downloads/content/autodesk-transport-layer-security-updates-require-revit-security-fix.html

This is related to this Github Issue and we are trying to pinpoint it ourselves. I would be curious to see what addins you have installed in Revit.

1 Like

I have updated to 2018.3.3 from 2018.3.2 and also reinstalled Dynamo still the same issue. Only solution seems to be unload Archi-lab package which I need.

We have traced the problem to an internally developed suite of addins.

2 Likes

Oh, sweet. Are you by chance referencing the Xceed.Wpf.Toolkit in your addins? That is the error we were seeing.

@Cahit_Okten please let us know more - you can contact me directly if you wish - I want to see if we can avoid this problem or at least communicate it better. Did you have any green notifications in your dynamo menu bar?

Yep that is what they are using.

Hi Michael,
Is there a suggested workaround for this other than not to use Archilab?

Thanks
Cahit

Hi,

Of course there is, because we have not had such a problem until this moment. It seems that there are shortcomings in your Revit updates, and these gaps are causing conflicts in the respective packages.
Please us share :

*What version of Revit and Dynamo are you using
*List of packages

My advice also makes all my updates, and after I delete all the packages, I would install with the latest versions of all packages.

Durmus

We know the issue is caused by the internally developed apps using Xceed.Wpf.Toolkit.
I was not aware you have never had such a problem before.
I am using the latest 2018.3.3 with Dynamo 2.0.2.6833.

I have not tried your suggested workaround does this get around the issue with the Xceed.Wpf.Toolkit?

Thanks

The dependency conflict can be removed by unloading the package or the add-in. That’s the easy way out.

Alternatively you could try the following:

  1. Update the add-in to use the same version as Archilab.
  2. Hack away at the Archilab package’s code (it is posted to the GitHub) to resolve the issue.
  3. Ask on the GitHub if the package owner could update to use the version of the conflicting dependency which you are currently using.

hi,
if you have Revit extensions like PyRevit…etc. try to move it to another folder :slight_smile: try again