Missing nodes in opening Dynamo graphs

Hello all,

When I tried to troubleshoot one Dynamo graph crashing Revit, I noticed a very strange behavior.
If I open this graph right after opening Dynamo, it crashes without any warning messages.
However, if I open any other Dynamo graphs and then open this troublesome graph, it opens and no crashes. In trying multiple times, it showed missing nodes like the screenshot below. After a few minutes, it showed the whole nodes like normal.
I suspect this display delay has to do with crashing issues caused by some sort of memory overflow. Has anyone experienced this kind of issue? What would be a possible cause?
This script has been working without any issues for a few weeks and it started crashing Revit this week.

Yes, many have. Try disabling all add-ins and see if that resolves the issue, as it’s usually related to a conflict there.

May also be related to a library bug which is being worked on (and has even impacted me lately). That can be resolved by disabling the library view extension.

Jacob, thank you for your reply. Can you let me know how I can disable the library view extension? I want to see if that’ll fix the issue.

Can you confirm that you disabled all your Revit add-ins? That’s more likely the cause and will result in a working environment whereas disabling the library will make Dynamo much less than useful.

My company saves all the packages in a locally shared drive, and I found several packages were not up to date. I installed all the packages up to date on my local computer and used that path instead of the shared drive path. The issue seems to be gone, while I still see the delayed display issue (showing only wires) for less than a second in opening the file. I’m going to update all the packages in our shared drive and test if the updating packages really resolves the issue or there’s a specific add-in that I need to disable.


Am I to understand I need to uninstall other vital addins in order for Dynamo to work properly? That is some nonsense!

I forgot to add an update to the issue that I had. The issue had to do with my company’s custom tracking node communicating over the network, but I still don’t know what part of that custom node exactly caused the issue.