Nodes and Wires Missing When Opening DYN File

That means we should avoid addins because we don’t know if they will break other parts of Revit as you said.

Is the Dynamo files are harmful ? or not similar to addins?

Right now I have no external addins except Audoesk addins. still I found missing nodes and wires.

That means you need to review them before rolling them out, as you would for any other software.

Do you have any errors in your Dynamo console?

No error. I loose some nodes and wires.

See attached, What I lost after reopen the same file.

change elevation of pipe.dyn (6.1 KB)

See attached I have loaded only a few Autodesk addins.

Hi @piuspatel1
can you add as much info as you can here:

  • revit version
  • dynamo version
  • dynamoRevit version
  • what happens if you remove System.Windows.Interactivity.dll from the Dynamo folder?
  • can you share the dynamo log (goto view -> console)

do you also have advanced steel installed on this machine with a dynamo addin?

Is the advanced steel addin something that came shipped with your revit install? Are all these addins ones that came with Revit or extras you installed?

1 Like

The System.Windows.Interactivity.dll seems to be a part of the pb.

Problem is resolved after I removed all plugins except Autodesk plugins.
I have concluded that don’t use third party plugins if you want to use Dynamos.

if you can id what plugin it was, it would be great, we can look at fixing it or contacting the author to align dll versions with Revit/Dynamo.

1 Like

It could be Taco HSS for Revit and Mitsubishi electric plugin for content.

1 Like

Same problem. Simple script. No import libraries. No packages. Dynamo for Civil3D. Script built from scratch in version

Save a DYN, or ‘Save As’, upon re-opening a File Path node and a String from Object node are gone.

I’m seeing similar problems with different nodes in several scripts in Dynamo for Civil3D. All with no packages or imported libraries.

What’s the point of Dynamo if you can’t simply save a file?

for Civil this is fixed in the current beta builds -

For my flavour of the problem (Dynamo for Civil3D), if i restart not just Dynamo, but also Civil3D, The apparently broken files open fine.

1 Like

Yes, the files are not broken but the dynamo instance is failing to read the dataset. As long as you don’t save the file you should be able to reopen it after completely closing all aspects of Civil 3D (most sure fire way to do this is to restart the cpu).

I can confirm it was Mitsubishi electric plugin, at least removing it worked for me as well. I tried to remove all the packages and addins first.

1 Like

Please report this to them - perhaps send them to this thread.

1 Like

I’m having the same issue on 2 fronts. Every dynamo script my company uses was created on my computer in versions of Revit 2019 and earlier. The missing nodes occur on other users computers, and I’ve tried removing all add-ins without any success. I also run into the same issue on my own computer when I try to open the scripts in Revit 2020. The only nodes that are missing are core Dynamo nodes like “List.Create” and “String” so it’s not even an issue with 3rd party packages.

Also worked for me when I closed and reopened Civil3D instead of only reopen Dynamo. Tks!

1 Like