Node deforms and stops working once the script is saved

Hello everybody!

I have encountered a very very weird problem. I made a pretty simple script that utilizes the JsonData package and has been working perfectly for more than a month at my company until today. It was deployed via the DynamoPlayer.

I recreated it from scratch and tried it again directly in Dynamo it worked perfectly. I saved it, opened it again and it doesn’t work anymore. I noticed that one of the nodes look a bit different after reopening:

Original script:

After saving and opening again:

Then I saved it and opened again:

Does anyone understand what the heck is going on?

As I said the script was working perfectly until now. There were no changes made lately in our Revit enviroment. We didn’t update Revit, nor Dynamo, nor the Dynamo Packages lately, nor the Dynamo Packages storage folder…

this happens when something else has loaded of some other version into Revit.

It could be that of some other version was installed in the GAC.

have you installed any other revit addins lately? Or other software onto the machine?

1 Like

Well… We are working in a VDI (Virtual Desktop Interface) Environment in our company and we divided it into three separate Images: Test, Development and Production. And according to our IT department, these are running from different machines and are separated.

Yesterday we (or the IT did) installed the “Roombook, Areabook, and Buildingbook” Extensions for Revit in the Test VDI so we can see if we can implement it in our workflows. Could this be it? Is there a way to check if this addin is loading another version of into Revit?

Or is there a way to check if two different versions are installed?

And even if it does it should not affect our Production VDI where the addin is not installed. Either that or the machines are not separated like the IT claims…