No preview visible in Dynamo

I get a similar issue, but I do not run on a VM or Remote. I run everything locally. The Revit preview works fine, but not the Background Preview.

Any suggestions?

 

I am running Revit 2016 service pack 2 + dynamo 0.9

Hi Jean, if you are running on a machine with integrated and discrete graphics, like many machines made these days you can try going into the settings for your graphics card and setting High Performance mode for Dynamo in the ProgramFiles/Dynamo .9 / DynamoSandbox.

It may also be an issue with a specific graphics card, what type do you have? Are the drivers fully updated? Version of Windows?

 

My Graphic card is a NVIDIA Quadro K2000M running on Window 7 on a powerful HP laptop (24GB of memory, SSD drives).

The NVIVIA control panel does not have a"High Performance" setting, instead it has a set of specific settings: Anti-Aliasing, Buffer-Flipping, etc. Any suggestion on which one I should adjust.

I tried changing a few settings with no effect.

Regards

Hi jean, Is it possible for you to put here screenshot of your graph. It happens due to: i) If the preview is not tick to the nodes. ii) make sure your in geometry mode.

Try this in geometry mode right click and set to zoom to fit.

Same problem, today i have upated Dynamo to 0.9.0.3067 and when i try to bring the geometry in, is not working…no preview…empty white screen…

Untitled

I just installed Dynamo and encountered a similar problem. The solution that worked for me was to open Dynamo straight from Revit (without using normal Windows shortcut).

Wondering if anyone has identified a fix to this problem? I’m also unable to see 3D preview in Dynamo 0.9.

I have an early 2008 Mac Pro w OSX El Capitan running VMware Fusion 8 and Windows 10. Graphics card is an ATI Radeon HD 2600 XT 256MB (standard Mac Pro card.)

In the VMware Fusion settings I’ve checked “Accelerate 3D Graphics.” There is a subtext saying it supports Direct X 9.0EX with Aero and OpenGL 2.1

When starting Dynamo, there are a few messages in the console that may give a hint:

“RENDER : Rendering Tier: 2”

“RENDER : Pixel Shader 3 Supported : True”

“RENDER : Pixel Shader 4 Supported: False”

“RENDER : Software Effect Rendering Supported: True”

“RENDER : Maximum hardware texture size: 8192,8192”


Any help would be greatly appreciated. Thank you!

 

Quick Update: Preview now working w the exact same setup simply by disabling “Accelerate 3D Graphics” in VMWare Virtual Machine Display Settings. Requires reboot. Noticed this above in Wassim’s post pertaining to Parallels workaround.

Side note, this does not solve any problems that may stem from DirectX being out of date, though I did find a documented issue on the VMWare Communities page that addresses this specifically. If interested refer to : https://communities.vmware.com/thread/522980?start=0&tstart=0

I am having the same problem. Dynamo 0.9, Revit 2016 and Windows 10 x64 no 3D preview what so ever.

After downgrading to Dynamo 0.8.2 it seems to be working.

I have no idea what the issue is but they should address this problem in future releases (btw vs 0.9.1 doesn’t work either).

I’ve run into something similar with other Autodesk products. Go into your Nvidia control panel (can be found in windows control ). In manage 3d settings window there is a “preferred graphics processor”. What most people miss is the program settings tab just above it. From there you can choose which programs use integrated or discrete.

I was having a similar issue with Dynamo showing 3d when launched from revit but not from the sandbox icon. looks like the add in is recognized as a revit instance and has acceleration turned on while dynamo sandbox was set to integrated. Made the change in the control panel and 3d background came back.

running on a MS surfacebook with windows 10.

I changed my computer and install revit 2016 + Service pack2 + Dynamo 1.0.0 / Dynamo 0.9.0 then, I got same problem! My OS is Window 7 professional K / Intel HD Graphics 530 yes,I checked Nvidia control panel following upper suggestion. I could found just downgrading to 0.8.2 is working as only solution.

There are a couple other threads along the same lines as this issue. Geneally we see this problem associated with machines that have 2 graphics cards, an integrated and a high performace one. Please check if this helps:

https://github.com/DynamoDS/Dynamo/wiki/Dynamo-FAQ

Q: The background 3D preview is not available.
A: Since Dynamo 0.8.2, Dynamo uses DirectX for hardware accelerated graphics. If the background preview is missing, your machine might have switchable graphics. Many laptops have two GPUs, a dedicated GPU (NVidia, AMD, etc.) and an “integrated” GPU (Intel HD Graphics). Graphics card manufacturers have each developed their own protocols for switching between your integrated chip and your “high performance” chip to conserve battery life. In most cases these manufacturers provide a control panel where you can specify what applications should use the dedicated GPU. Autodesk has published a number of pages for different applications on dealing with these issues. We recommend you try some of the solutions listed here.

1 Like

I’ve tried many of the solutions presented throughout here and with Autodesk. This includes attempting the “Switchable Graphics” toggle (that option does not exist for my graphics card). I’ve even downgraded the Dynamo. The background is still not showing. I have an AMD - ATI Radeon HD 4600 Series graphics card on Windows 10. Revit runs fine with this, however, not being able to view the Dynamo Background is a bit challenging. Is there an out of the box solution being developed? Or is there another workaround not presently being debated. Thanks for all of your helpful work.

Hi Samuel - that card is kind of old, older than Dynamo I think so we probably have not tested it, BUT it does support direct x 10.1 so I think it should work.

It may be possible to force Dynamo to run under software rendering so you can atleast see the background preview… it requires installing some developer tools… I would not recommend this as a real solution only as a last ditch effort:

Hi

This problem appeared when i upgraded my windows into windows10.
This is how i solved it:
-Uninstalled the graphic driver from the device manager and check delete.
-Uninstall the graphic application.
-restart your computer.
-from Start go to setting and press update.
-the widndows will detect and install the driver.
-Go to


and download Intel update utility.
-Run the update utility.
-Restart your device.
-Go to power options…change plane settings…change advanced power settings…switchable dynamic graphics… and then set - on battery and pluged in (maximize performance).

Enjoy:)

Hi,

I had the same issue and this was the only solution, so check it out, I hope ot helps u :slight_smile:

Hello i am using yhe W10 unniversry update and its not working at all. Even if I uninstalled the drivers.

Actually i fixed my problem, i reinstalled windows at all i done all updates available. Only after that, i reinstalled all autodesk softwares. And now it works.

Hey, guys!

I had the same issue with background preview.
I tried lots of different solutions, but they did not work. Finally I tried to switch off one of the graphics adapters, and after this I see this error on the background. I switched on both graphics adapters, but nothing changed.

I have Windows 10 Pro, Revit 2017 and Dynamo 1.3.0.875.
Graphics adapters are ‘AMD Radeon 6600M and 6700M Series’ and ‘Intel® HD Graphics 3000’.
My graphics settings are on the high performance.

Do you know any solution for this problem? Please, help.



Well, I solved this issue by switching off one of the graphics adapters, then I switched it on again and restarted my laptop.

But the preview still does not work.