Need a Family with Volume for my Solidbyloft element, error - TypeError: expected Solid, got Mesh

Hi I’ve been trying to create a Family with my solidbyloft element, I tried spring nodes Family instance by Geometry and Familytypebygeometry. I need a family that generates volume automatically

@Dynamobeginner ,

Can you share some screenshots… whats the aim?

Attaching image

Hola Amigo @Dynamobeginner 2 weeks ago I had the same problem, with this node you must specify the material, make sure that the project template or your project you are working on has at least one material loaded, if it doesn’t, create one, I leave the screenshot below, I hope this helps you fix your problem!


If you are In 2022 you Can try synthezise toolkit…have a node family insert as should work In 2022

1 Like

I Tried using Familytype.bygeometry

I checked with material and solids, all is loaded
Now This time I’m using Revit 2020 and in Family Templates.

What I’m Trying to create is make a family of multiple families with respective volumes (Nested) from solids from solidbyloft


The above method doesn’t works, Maybe i am doing some thing wrong

Next, I tried Spring nodes Familyinstance.bygeometry

and this is the error I’m facing. Again I’m using Revit 2020

1 Like

arhh you are in family …think synthezise have a node for that as well

I tried using Synthesize tools, But I’m not much familiar with it , this is the error for Revit 2020 family template

Please find my script flow

Hello @Dynamobeginner …what happens if you do as shown…if you hoover over the inputs in the node. then you can see what it expects…and actuelly material, categori etc…is already defined…but offcourse you can made your own input…but try to disconnect them and only input your solid and see it could work …

and should work in family creating as well :wink:

1 Like

@sovitek Thanks for your response. I’ll Check this out