Metamorphosis not working

I am trying to use Metamorphosis with Revit 2019 and dynamo 2.0.2:

but it is not workig:

Error: Index out of range

Any idea what is wrong?

The DYN for that dates back to dynamo 1.2, and you’re using 2.0 by the looks of it.

Try Dictionary.Keys as a replacement.

1 Like

Thanks!! I could move one step forward. Now I have to redo the whole list structure…

Is anybody using Metamorphosis with Dynamo 2.0 ???

I would ask on the issues page of this project’s GitHub page, here: https://github.com/mattmas/Metamorphosis

The issue isn’t with metamorphosis. The issue you are talking about is with processing the Json into Dynamo. in Dynamo 2.0 there are many great new tools for processing lists like the Dictionary.ValueAtKey. This should be able to get you the lists of data you need to create the Mandrill reports you are looking to create.

1 Like

Hello everyone, I got some issues regarding this Dynamo. I’m with Revit 2018 and Dynamo 2.0.2.

When I tried with Dynamo 1.3.3, Mandrill crash everytime and I’m forced to close Dynamo.

And with 2.0.2 I have to change all the List organisation with new ones in 2.0.2.

But I’m not really good at Dynamo and the author of the Dynamo doesn’t answer on Github :confused:

Did someone can give me some photos of the Dynamo with correction or the script please ?

Best regards

Best to start a new topic posting what you have tried, what your graph currently looks like, and clearly describe your problem.