MEPover package published

#1

Hello everyone,

I’ve created some custom nodes which focus mainly on the MEP side of Dynamo/Revit. It’s my first package that I’ve uploaded to the package manager website so I hope it all went well.
I would love to get some feedback on the nodes whether they work as expected or things that I could improve upon.
Just search for MEPover on the package manager website or from within Dynamo.

I’ve put up a few short explanations for most of the nodes here: https://sites.google.com/site/bimstallatie/dynamo/mepover-package

12 Likes

#2

funny works, thanks a lot

0 Likes

#3

Hello, and thank you for creating that.
I tried to use it yesterday but it didn’t work and I couldn’t figure out why.

0 Likes

#4

The problem is probably the conduit type. You have to feed it an actual conduit type. Look for the node ‘Element Types’ and connect that to the node ‘All elements of type’. Look up ConduitTypes in the first node to get all the conduit types, including EMT.
Please let me know if that works.

0 Likes

#5

We suspect this, however, nothing is working. Dynamo does not understand conduits.
we even tried getting the type ID and trying to use that …

0 Likes

#6

You are still feeding it a string instead of the actual type. On top of that the curves schould be dynamo curves or lines instead of Revit model curves.
Not at a computer at the moment, but maybe this example of a cable tray will help:

Found a computer :slight_smile:

2 Likes

#7

Hi T_Pover
I try to understand your package, it’s awasome!!, but i don’t run


Please could you help me?
Thanks

0 Likes

#8

Hi Justo,
You’re feeding it a cable tray, but it should be a cable tray type.

0 Likes

#9

Sorry T_Pover
i try diferents options, but i don’t find the solutions

0 Likes

#10

T_Taco
it’s ok!!
Thank’s for all!!!

0 Likes

#11

First of all, thank you very much for the package, it really does an excellent job.

However, for some reason the nodes of your packages stopped working and its results are all nulls.

The main issue is that was working and when I updated to revit 2018 this problem began.

0 Likes

#12

Which version of the package do you have installed?

0 Likes

#13

Version MEPover: 2017.8.1
Version Revit: 2018

I see now that the problem is on MEP conector info node as you can see below. Whereas the other node works fine.

0 Likes

#14

That is odd, works fine on my end with Revit 2018:

If you copy out the python node and use that instead, do you get an error message? If so, what does it say?

0 Likes

#15

Warning: IronPythonEvaluator.EvaluateIronPythonScript operation failed.
Traceback (most recent call last):
File “”, line 44, in
File “”, line 44, in
File “”, line 44, in
File “”, line 44, in
File “”, line 44, in
SystemError: The type initializer for ‘Autodesk.LibG.LibGPINVOKE’ threw an exception.

I had already reinstalled the package and dynamo. Do you have any guess what might be?

0 Likes

#16

Finally!! The problem was the conflict between Revit 2017 and 2018.
For some reason some old files from Revit 2017 were still on my computer and probably Dynamo has being confused and now it works!!!

Thank you for the fast response and help!

2 Likes

#17

Good to know you found the cause, because the python error was nothing I’ve seen before :smile:

1 Like

#18

Hello T_Pover.
First of all, thank you for the package. Good job!

I tried the MEP Connector info and got a list of ConnectedElements.
Is it possible to get the ConnectedElements as before and after the element depended on the flow direction in the system.

image

Image: No 1 is before, No 2 is the element and No 3 is after. The blue arrows are the flow direction.

Kind regards

0 Likes

#19

Hello Christian,
I won’t have access to a computer for the coming days, so from the top of my head: I believe the ‘info’ port on the node gives you the direction of the connectors. So with that you should be able to figure out the order of the connected elements.
Please let me know if that’s not what you’re looking for, then I will look into it next week.

0 Likes

#20

Thank for your reply.

I will check on that later today and reply with and answer (or more questions :wink: )

0 Likes