LunchBox install from website


My LunchBox package dropped off the face of the earth, and I see that I now need to download from proving grounds. I tried the installer, but it seems only to apply to Grasshopper. I downloaded the whole repository, but now I don’t know what to do with it. I dropped it in the package path where all the other packages reside and no dice. I’ve restarted my machine. I simply don’t know what to do to access these nodes again.

Can someone point me in the right direction?

Have you tried reaching out to the proving ground team directly via the website to let them know of your issue? There are a few old versions of the package being distributed on the forum if you look around enough, but since it’s a repeat issue they likely should be given the heads up - I know they don’t intend to block things for everyone.

Not sure if this has to do with it but I think proving ground discontinued all Dynamo packages in favor of Rhino Inside / Grasshopper.

Quote form their website. " ** Note that we have discontinued the Dynamo versions of this tool. Current and future versions of LunchBox are built for Grasshopper. The source code for the Dynamo version can be found here under the GNU license.*"


Ouch. I only read the notifications in the package description. That hurts.

I think you can still download it from the package manager no?

I uninstalled and reinstalled, but it doesn’t show in my tools.

There are some other posts on here about packages not showing up. I would search for some of those. Something to try though is to remove all packages except for lunch box and see if that works. If it does load packages one by one until you find the culprit. If this does not do the trick start Revit with all addons disabled.

Thats all I have for you. Other posts may have more info.

Proving ground should hear this directly. :slight_smile:

@JoeB See if this helps.

1 Like

Definitely worked. Unfortunately, it seems the nodes I need are in the latest package. E.g. “Get Revit Link File Path Information” and “File Size in MB from File Path.” I suppose I’ll need to recreate the workflow without LunchBox.

1 Like

@JoeB I’ve never used those two nodes but I don’t think they belong to LunchBox.
As per this git repo they are a part of Bakery. Try installing that package.


OMG, I think you’re right… :sweat_smile: