Lag..Latency...Dynamo Search Extremely slow

I am having some lag latency issues with the search feature in Dynamo when I am on my work network.

Any other networks seem to be fine…I am thinking that somewhere along the line I am pinging or communicating with a remote server as my company has a vast global network.

Network Information:
WAN Network…here in North America…That is also connected to a global network…

I kinda sorta found a work-around. But it does not work with A360 models and limits some of the functionality of dynamo.

WorkAround:

  1. Open Revit along with any file.
  2. Disconnect from network
  3. Open Dynamo (while disconnected)
  4. Reconnect to network

This works okay and definitely minimizes the lag… but not completely there is still a brief pause…
When working outside of office (on my personal laptop)… Dynamo & Dynamo Search function FLY! no lag at all. Which as you all know the flow of these inputs is vital to a fluid thought process and workflow.

Problems with this workflow…

  1. After disconnecting (even briefly) I am not able to work on A360 cloud based projects…
  2. it is annoying to have to remember to disconnect and reconnect the network everytime I open or close Dynamo

Does anybody know how to (maybe through the dynamo log files) be able to look at the directories that I am communicating with and possibly disable or block the ones that are causing my headaches…

Thanks in advance to any advice, input, and or possible solutions with this.

Can you post a screenshot of your manage node and package paths dialog box?

@Racel @Zach_Kron @Neal_Burnham this is very interesting. Analytics perhaps or pinging the package paths?

Yeah I will… when I get back into the office.

What version and point release of Revit and Dynamo are you working on. Digging into some of the crash reports, I see some weird stuff with some versions hitting Analytics errors, but not all

image

Yeah nothing weird going on with paths…

I’m not sure about that - what happens if you disconnect dropbox from updating?

well I run it on my other Laptop and there are no Issues…But I can try

Dropbox trying to sync live vs not would explain the difference on the two systems. It tends to behave differently on various installs. I would be interested in seeing what packages are on that Dropbox location. Also can you confirm you don’t have the same package in both directories as I’ve seen that cause issues in the past (save version or not), which is another thing that can cause differing performance between the systems.

Looks like a different version of Revit (2017) than what I’m seeing associated with Analytics errors (r2016). Agree that Dropdox seems like a likely suspect. That being said, I’ve always pathed my packages to Dropbox folders, and also frequently have the same package in multiple locations and never seen a search slowdown. Doesn’t mean that isn’t the cause, just that there is some additional variable. @emmett.cruey what OS are you on? (My systems are Win 8, occasionally a Win 7). Also, worth checking antivirus and firewall settings.

1 Like

Having the same problem with projects located on the server of my company. It doesnt apply if I save the projects on the local drive. The packages are installed on the drive.

The workaround proposed in OP (disconnect, start Dynamo, reconnect) works. It seems disconnecting once will work for several subsequent openings of Dynamo.

Revit 2018 and Dynamo 1.3, packages on default location (local C://).

Jacob,

I have since moved jobs, and am not using that same set-up.

I am still using DropBox but from my own machine and server, not dealing with the WAN.

Thanks for following up.

Could you clarify what you mean by disconnecting? I am working on a remote server and don’t like the idea of removing the link to the central model because we have lots of people working on projects and I think it would lose it for good. Is there another alternative?

Hi Simon, I meant disconnecting from the internet, the point of which was to break the connection with the server.

1 Like

I would literally disconnect the internet boot up dynamo and then reconnect my machine.

The problem was never figured out but this was the only way I was able to get Dynamo to function.

I hope that helps.

1 Like

@simon_murphy1
did this help your issue, or just happy to see a response?

I didn’t like the idea of disconnecting so I have a detached central model on my desktop that I open to build the dynamo scripts in. When the script is complete I run it in the main model. It seems to run scripts ok just can’t build them.

It is a thread which has been going on some time, however, since it appears again I can contribute with my experience of the usage of Revit. I think it is mostly a Revit issue and not that much a Dynamo issue.

I have for several years been challenged by helping students projects. We have many projects using work sharing, and whenever something happens am I being invited into the projects to help. That way do I end up with many projects which are dependent on networks access.
It is only the last couple of projects which is shown, but if you open the revit.ini files you will see that it remembers a much longer list.

This is why I from time to time manually cleans up the revit.ini file so it is being reset. This helps a lot concerning time both in Revit and in Dynamo.

Therefore do I think that is is mostly a Revit issue and since Dynamo waits for idle time being sent from Revit… However, there could of course also be issues with Dynamo, if many packages is loaded and so on.

Lastly… being dependent on packages placed at dropbox is a very bad idea. This can be solved much smarter. I have made a post concerning this here.

1 Like