Known Issues in 0.7.4 release


#1
  • Element.Geometry may cause a crash in Dynamo versions 0.7.2-0.7.4 when run in Revit 2015 when executed on large groups of Revit geometry.

  • Upgraded Excel.Write nodes will show as “Unresolved”. They can be replaced with Excel.Write to File nodes.

  • View.ExportAsImage will only export {3d}

  • Cancel does not work when executing Cloud based Renderings, this includes Daylighting.

  • Dynamo can fail to launch in Revit when Unifi, Maxwell, or Kiwi Bonus Tools add-in is installed on Revit 2015. If you have one of these applications installed, or find that Dynamo fails to launch from the addins menu, this is fixed in the latest Pre-Release Builds.

  • Existing Code Block Nodes may be affected by name collisions with functions that come from installed packages. For instance, Point.ByCoordinates is affected by a collision with a Point. operation in the popular Rhynamo package and will throw an error saying “Warning: Dereferencing a non-pointer. Dereferencing a non-pointer.” To correct this, re-enter the function in the code block node, autocorrect will indicate a more specific refererence.


#2

Thanks Zach.

Lewis


#3

If anyone is wondering why Read From Excel isnt working anymore in the new version, it doesnt seem to accept a string as an input anymore.

Use File.From.Path to convert string to file.

(Just had to fix a couple of things…)


#4

hey I got an issue with the Element.setparameterbyname

the block can read only identity parameters and not new instance parameters that I made how can I fix this problem ? thank you for the help

printsc2

printsc


#5

I just downloaded and installed 7.4, and my Dynamo will no longer work. I don’t have any of the add-ins that you mention. Is there interference from other plugins that are known?

Steve Fong


#6

Just got back from AU and installed the latest version 0.7.4.3245 and it will not launch from within Revit 2015 (UR4) but will launch in Revit 2014 and Vasari. We do not have any of the add-ins that you mention either.


#7

After update, I got this error in many nodes, I cant do nothing now. The folder it looking for dons’nt exist (dynamo 0.7/dll/…)

Something to fix it?

thx


#8

There are other addins that may have the same feature that is conflicting with Dynamo launching. Try one of the pre-release builds, as the conflicting Addin problem has been fixed there


#9

I’m sorry Zach, I’ve tried all the 3 pre release and the 7.6 too but always the same problem.

It seems always the wrong path, missing every installation to create the dll directory.

What can I do?


#10

Hi Fabio,
It looks like you are running Dynamo in Stand-alone (launched from outside Revit/Vasari), the Revit specific nodes will look like that unless you are running Dynamo inside of Revit/Vasri.
The point errors are a different matter, looks like it is having some trouble finding geometry libraries that live in those folders
What is your Revit or Vasari install path?
Do you have an expired Revit or Vasari?
Are you on Windows 7 or 8? 64 bit or 32?

Thanks
Z


#11

I’ve tried some clean reinstallations, now it seems works correctly but only if started inside revit.

Btw if it can help you, I leave you the answers:

current dynamo version : 0.7 stable build

revit installation path: P:\Autodesk\Revit 2014

installation path: p:\dynamo 7.0\

Win 7 64bit

Thank you a lot