Iterating Dynamo Definition W Revit Objects


#1

Hello Dynamites

I am trying to drive a small test building geometry parametrically through Dynamo. This geometry will then be converted to Revit elements either in Dynamo or through the Revit interface. I am running into the following issues:

  • If I create the geometry entirely in Dynamo, and use import instance into a mass family, I can create elements in the project “by face.” However when I update the geometry at a later date, all the “by face” elements are deleted because they can’t find their original hosts. I thought Dynamo updated the geometry? It looks like its recreating it instead.

  • Next I tried to create reference lines form Dynamo and either create forms form these “bones” or snap points / lines to create forms from, and the same issue presents itself. The forms get deleted if created directly from the Dynamo reference lines, or the points get left behind if a parameter is changed in Dynamo.

Has anything broken with regards to the Revit / Dynamo interoperability? I have tested this with the latest stable release 0.8.2. Which the latest dailies (0.8.3.20150921T0452) the Revit geometry is not even instantiated.

I tried this first with an adaptive Revit family, but the constraints brake easily and its not robust. The constraints work wonderfully in Dynamo, but then you can’t update the Revit elements after design iterations.

04 - Dynamo ImportInstance

 

 


Dynamo > Conceptual Mass > Project
#2

One possible approach that should solve your problem is to use Direct Shape in 0.8.3

File: DirectShape.dyn

20150923-3


#3

Thanks for the suggestion Vikram. The problem is those are not real Revit elements with components, so when I cut a section they don’t show proper layered materials. DirectShape is essentially what you get when you explode an imported solid.

Dynamo team: is this a temporary regression or have we given up on the ability to keep associativity between Dynamo and Revit geometry?

Here is another example that shows the problem clearly:

02 - Subsequent Iteration

 


#4

I believe import instances do not do rebinding, so the element Ids will change, but reference lines should find their hosts, that seems like a regression can you open a detailed issue on the github. We are tracking a similar bug with adaptive components as well so it is on the radar.


#5

Ok I will. The only time it updated is when I created a model / reference line from Dynamo created points. Otherwise it creates new elements.