Issues with Dynamo-MySQL connection

Hello! I am trying to connect Dynamo to my database on MySQL Workbench, but I failed. I read a lot of previuos posts on this forum, but I still do not understand where I am wrong. Can you suggest me what to do to ensure that the connecton node works?
I tryied the 127.0.0.1 server and localhost too. I tryied different connectionTimeout.
The same query works on Workbech.

there is nothing obviously wrong with your Dynamo graph- it should work
(assuming you are running Dynamo on the same machine as mysql workbench and the server)

Also assuming that this query works in workbench i.e is not permissions related

The issue is probably with the server configuration, probably with security or connection settings. Try this:

  • the the actual IP address instead of localhost or 127.0.0.1
  • check the connection settings in workbench to see if anything like SSL or keys/certificates is being used

mysql does tend to be complicated- depending what you are doing I’d recommend SQLite, PostgresSQL or MSSQL (the free one) Refer some of my other posts on this forum

Thank you for your reply.
I have Dynamo and Workbench on the same machine.
I was actually using PostgreeSQL, but as that database is not on my machine I switched on Workbench.
The query works on Workbench and I checked the privileges, for the user ‘opim’ they are all activated, both administartive and schema privileges (is it good?).
The SSL is not used.
I tried the actual IP address, it is not working.
I also tried another connections after having configurated the driver MySql ODBC 8.0 Unicode.
I then tried to use Dynamo sandbox, that reports a more detailed error on the query node:‘Object reference not set to an instance of an object’.
Do you know how to interpret it?
Thank you for your time and patience.


I don’t know- it is very difficult to diagnose remotely.
Can you create a ODBC connection, and import the data say in Excel ?

Unless there is a very compelling reason to use mysql- I’d seriously look at the other options I suggested
SQLite is the simplest- just a single file- not ports, SSL, named pipes, schemas etc to worry about

Hello,
at the end I tried SQLite and it works!
Unfortunately I have to manage to fill this new database, but at least the connection works.

BTW the database on Workbench was connected to Excel.

Thank you for your support

I believe there is a Workbench plug-in (Python?) which will export from MySQL—> SQLite

Otherwise, there are other methods