Isolate element in view

Hi,

I could use some help.

I am trying to isolate 3 elements which are spread over 3 views, each in their specific view.
The clockwork node Element.PermanentlyIsolateInView seems to be the node that I need. I would prefer to use an OOTB node, but I think there is none.

Somehow I cant get the node to work.

The list structure of the two input lists seem to match perfectly fine.
Lacing is set to longest.
Also tried chopping both input lists into sublists of length 1 but that did not work.

Also what I find strange is that the node shows resulting data (three lists with view and element). So there is no null value. But still, in the views I am seeing all other elements.

Do you have any advice for me ?

I am using Revit 2017 and Dynamo 1.2.2.

Many thanks in advance.

Try changing the view input to @L1

Thanks for your reply!

Sadly, no result though.

2018-07-05%206

By the way, just so that you can get an idea of what I am seeing. This is the resulting view. One of these cubes is the element that should be isolated.

This one to be exact:

Ah apologies I just tested - it should work with view @L1 and the element input @L2 (however I am running Dynamo 1.3)

I’m sorry, still no …

You’re saying it’s working for you on Dynamo 1.3? Maybe I should upgrade…
However, I would still prefer to find a solution within this version 1.2.
Could it be that the nodes are built for the newer Dynamo version?

2018-07-05%209

Also i fount this similar topic.

Same issue, as in that the nodes are also not working for a list of views.
Sadly the guy found a workaround. Would love to see how to get the regular nodes to work :slight_smile:

Still, many thanks for your support already

Which version of Clockwork are you using? Clockwork for Dynamo 1.x should work with list levels; this is taken from the github page:

Please note that Clockwork for Dynamo 1.x is the only Clockwork version fully compatible with Revit 2017 & 2018. It has been tested with Dynamo 1.3.1 against Revit 2016, 2017 and 2018. Also note that some nodes in Clockwork for Dynamo 1.x v.1.31.0 and later use the list@level functionality introduced in Dynamo 1.2.x and may thus not be entirely compatible with older Dynamo 1.x versions.

If you are using the correct package version the next step would be to hit Edit Custom Node and copy and paste the node’s internal contents in its place to see where it is failing

Looks like i am using a 0.9 Clockwork version.
I will try a 1.x version.
Thanks

Strange. I found an older script I once made, where I got the same node to work correctly (using the same versions of Dynamo and clockwork).

What could be the difference?