Is there anyway to tag rooms of linked Revit model

Hello Everyone,

I looked into similar posts and found no answer, the only screenshot that seems to be helpful is the following,

BTW, it does not work. NO room will be tagged if you follow the above workflow!

I need someones help to find solution to the below workflow.

I think I will need to generate list of views for each room in the building similar to the list of levels shown.
I guess will need to generate 147 views and link them to the annotation tag node to be able to tag the entire rooms in all views of the building.

This might be confusing but if you get what in the screenshot please assist in solving this issue.

Thanks!

This topic is related Tag Rooms by Parameter - Problems with the 'Create Annotation Tag' node? , might be of help.

Thanks, I will look into it.

This is way above my level in dynamo! lol

could you please explain what is the use of (select parameter to filter) I think I need to enter something other than the word “Department”

Thanks.

Basically tags are associated to views, so you need to specify on which view you want to place them.
If you just want to tag one view at a time, will work just by selecting it using the Views OOTB node or selecting the active view, also using out of the box nodes. You will also need to specify the link instance on the LinkInstance input.

Tagging multiple views on a single run requires to cycle the inputs according to the number of views, which is what is happening on your first screenshot. :slight_smile:

I appreciate your reply, I need to tag the entire rooms with a single click.

What you’ve explained is exactly what I want to do in my second screen shot. I already know that tags are associated to views. I want to determine the way to specify those views and link them to the annotation tag node.

If you review the box - that has text in it - in my second screenshot represent the missing part of my workflow. The cycle node you mentioned make sense but the problem is that every room in the list is associated to its specific view and level. The cycle node may mess up tags if I am not mistaken! On the left side of that box are levels associated to rooms. I made that for tracking and reference only, it can be deleted later on.

Thanks

Hi @msulttani,

You can use the node “Create Annotation Tag (Multi-Category)” from the package Genius Loci.
It’s a variation on the node from Archilab. (Thanks to Konrad)
You don’t need anymore to cycle your list of views and can tag all your views at once.

1 Like

Thank you Alban for your respond, I created exactly the same work flow. Everything worked fine except no tag were created on plan views!. I get blue dots only. please see screenshots below,

Never mind! it did work to me thanks alot

Hi @msulttani! I seam to have a similar problem, where the Create Annotation Tag node shows that it has created room tags, but they don’t show up on the views. Could you please tell me how you solved it?

use the following node: Create Annotation Tag (Multi_Category) and make sure to match phase mapping of the link and your model.

OK, thanks, already got it! :+1:

Hi !

I´m continue with the blue dots , I used the "Create Annotation Tag ( Multi_Category) …

Apprecciatte some help! Thanks !

image

thanks!

I am getting the same issue. I created 3 different scripts. The 1st one didn’t work (for all views). The 2nd one gives me the blue dots (for all views) but no tags and the 3rd one only places tags on the current view but works.

_PS-Tag Room Names.dyn (22.8 KB)
_PS-Tag Room Names 2.dyn (18.5 KB)
_PS-Tag Room Names By View.dyn (21.0 KB)

Hi,

The blue dots are only a dynamo preview. Once Dynamo or Revit will be closed, the blue dots will disappear.

1 Like

Thanks. I turned off the Revit preview in Dynamo as well

Hi,
Please notify that nobody found a solution to make this script works.
We still cannot tag all room in linked model in one clik (all views).
We really need this script so please if somebody succeded let us know.

@sahar.kanzari
you will need to use Create Independent Tag node, see work flow below. create similar work flow and you will be fine.

1 Like

@Alban_de_Chasteigner
@msulttani
HI,
I just updated all the used packages and it works!!!
Thanks a lot for your Help!!

Glad to help