Intersect Geometry - How to Divide surface


Rookie here and this is my first real project that is using dynamo. I’ve been having success. But I think I hit a brick wall. I was able to have my Ref line intersect the geometry. But I have a few questions:

  1. My revit geometry is broken into 4 faces. (If it were up to me, I would make it 1 face). In dynamo, I want to use the select faces (plural), but dynamo won’t let me. As a work around, I use the select face. But then I have to do everything 4 times in dynamo. Why am I unable to use the select faces node?

  2. Now that I generated lines on the faces, I want to a UV grid in replacement. How do I do that? I eventually want to place a curtain panel.

  3. The third question is more advice. Would you have gone the same dynamo approach? I have a feeling that there is a better approach.

Thank you very much everyone.

Link to all files














divide suface_1

Leaf Option_2015.02.01

In the following topic, Zach explains how to use the “Select Faces” node.

Have you had a look at the Lunchbox for Dynamo set of custom nodes? You will find a lot of options for paneling there.


My knowledge of dynamo really shows based on my first question. thank you for that easy solution.

I am still having issues with creating points at the intersecting geometry. I dont think I can use the strategy you are showing because the U grid (radial grid) doesnt have a consistant pattern. the V grid is equally spaced by 32.

thank you guys!

Then it might be simpler to select each face individually and experiment running it through your preferred mode of generating the points. That way you will have a finer control of the divisions.

Once you know your divisions, you could try combining the Lunchbox node like this:



The division is already determined by a cad underlay. I cant seem to get the same layout with the strategy you are suggesting. The radial spacing is equal (32 ). But the the linear grid is unequal. Also I need a point at the corners where the 2 major shapes meet (item 1 & 2 on screenshot).

Using the code block I am only able to specify equal spacing.



I’m not sure how you could make the linear spacing unequal computationally. Hopefully someone else can pitch in. Why are the points not bound to the surface? That’s unexpected behavior.