Installing Dynamo

Hi all!
Several times I've tried to properly install Dynamo, never managed it. What am I doing wrong?
I've downloaded the latest Vasari 2.1, from the Autodesk Labs site I've downloaded the installation of Dynamo, during installation everything went fine, ran Vasari and there is no toolbar in it from which to launch Dynamo.
When I click on Vasari icon, it just runs, does not installs. What should I do? How to install Dynamo?

Regards, Neboysha.

Ah, sorry, same process is needed for Revit 2013 and Revit 2014 if you are having this problem with them.




Dynamo is going to continue supporting both Vasari and Revit moving forward.

Moving the .addin file worked for Vasari. Thanks!

It is still not an option in the Revit 2013 addin, is Dynamo only going to be an addin for Vasari and not Revit moving forward?

Thanks for the help Zach! This is my first go at Vasari so I am probably doing something wrong, but I drew a couple quick masses to see if I could analyze them but the features where still grayed out. I need to do some more reading about Vasari's functionality.

I am on a 64 bit system.

I'll give option 1 a try and see if that fixes the problem. Ill let you know.

Could be one of 2 problems:

1. When installing as an admin the addin gets installed to the admin account space and you (a typical user) can't see the addin because it's not installed for you.

To fix the Dynamo issue you can either use one of our development builds (bleeding edge stuff, where we have fixed this issue or you can manually move the .addin file from




2. There is a conflict with the ModelReview addin. You may have to uninstall this addin.

Are they ever NOT greyed out? That is, can you use them? Also, are you on a 64 bit system?

Yes they do.

Hi Chris,

Do the Solar Radiation, Wind Tunnel, and Wind Rose tools show up in the Analysis tab in Vasari?


Hi Matt,

I am having difficulties installing Dynamo 0.5.3 on my work pc. I had my IT department follow the instructions, but Dynamo still does not appear in the add-ins toolbar in revit 2013 or Vasari 3. Do you have any further information that might be of help to me?



thanks,i have look for a long time

We have seen this a few times.

We have seen this a few times.

0) uninstall previous dynamo addin first.

  1. you need to run vasari 2.5 at least once on tha machine before installing any wip to create the correct directory for the addin.
  2. If you don’t have admin rights on the local machine while installing the wip it looks like the installer may fail to write the addin file. We’ll look into it.


Hey guys,

it didnt work for me either.
The problem seems to be that the addinfile isnt placed in this folder:


You can get it from the gitHub-site:

Place it there and replace this line:

C:Program FilesgoBuilddynamoDynamoRevit.dll

så that it points to your DynamoRevit.dll-file.

The default location is this:


Good luck!


I have exactly the same problem. Dynamo seems to install.. but it doesn't show up in the add-ins.

I looked at that website but that didn't work either.


after instalation it should be in add-ins on the ribbon. if not try again with this