Installation problem - Dynamo 2.0.3


I’m experiencing an installation issue with Dynamo 2.0.3 in Revit 2019.2 and Windows 10 Professional. The error message below appears:

I tried the following steps to resolve the issue, but it persists:

  • I removed all versions of Dynamo Revit and Dynamo Core from my system
  • I just installed Dynamo 2.0.3 again

I also did a search here on the forum and found the topic below. But the information on this topic did not help much.

Dynamo 2.0.3 error installation

Any suggestion?

try removing all your existing packages under %appData%/Dynamo

I haven’t your same problem but I solved mine reinstalling whole system.
I know that isn’t a good solution, sorry.

Hi @Michael_Kirschner2!

I don’t have any packages installed.

As you suggested I checked the% appData% / Dynamo folder, but since I don’t have any packages installed, there is no way to delete this folder.

Would you have any more suggestions?

Hi @leoflazio!


When you say you reinstalled the entire system, what exactly did you mean?

In my case I uninstalled all items related to Dynamo through the Windows control panel, restarted my computer and reinstated Dynamo 2.0.3.

This procedure did not work. The message I posted at the beginning of the topic continues to appear.

I reinstalled Windows like fluffyhugger suggested to me in the topic and it worked for me.

In my case I installed different versions of Revit and Dynamo during the years and I think this was the problem or another software that was in the system.

OK, @leoflazio!

Unfortunately, I can’t format my computer because of Dynamo! :frowning:

Anyway, thanks for clarifying my question.

I will continue to look for a solution.

Hi @Ari_Monteiro

Do you have any other addins in Revit?

Bonjour a tous, je commence sur le forum donc j’espère ne pas me planté de lien,

Voilà, je viens de suivre une formation dynamo, j’utilise REVIT 2019 et j’ai donc installé une version dynamo 2.0.3, de là mon intervention sur ce Forum.

Je n’ai pas de problématique à utiliser Dynamo version 2.0.3, par contre lorsque je lance Dynamo, j’ai la possibilité de choisir la version de dynamo que je souhaite Utiliser. Voir photo joint

Pour mon cas Version 1.3.4 lors de l’installation d’origine et l’ajout de la nouvelle version.

Question? Quand je vous lis je ne suis pas certain qu’il faut que je désinstalle la version “Origine” Mes autres collègues semble avoir la même configuration?

Y- a- t-il un retour d’expérience sur le fait d’avoir supprimé l’installation d’origine et remplacer par une nouvelle version? Et cela fonctionne t-il?


Hi Patrice,

There are several drawbacks to having two versions of dynamo. This dialog box for getting started and managing different package versions. (Some packages only work with Dynamo 2.X)
You can keep or delete Dynamo 1.3.4 according to your preferences.
Dynamo 1.3.4 can easily be uninstalled or reinstalled.

Dynamo 2.03 works perfectly with Revit 2019.

Il y a plusieurs inconvénients à avoir deux versions de dynamo. Cette boite de dialogue pour commencer et la gestion de versions de packages différentes. (Certains packages ne fonctionnent qu’avec Dynamo 2.X).
Tu peux conserver ou supprimer Dynamo 1.3.4 selon tes préférences.
Dynamo 1.3.4 peut facilement être désinstallé ou réinstallé.
Dynamo 2.03 fonctionne parfaitement avec Revit 2019.

Super, Merci Alban, je viens effectivement de le désinstallé, pas de problématiques particulières.


Hi @Kulkul!

No. I haven’t any addins instaled in Revit.