Input combinations working in Dynamo but result in no values (*) in Generative Design


I am encountering an issue when using Generative Design for a project. I am not able to reveal too much about the project but I have managed to reproduce the issue with a smaller Dynamo script.

The project consists of creating a 5x5 surface on which I draw a grid. From each point on the grid, I cast rays in a given vertical and horizontal angle (120 and 360 degrees respectively). The grid size can be as small as 0.25x0.25 and as big as 2x2; while the number of rays can go from 10 rays in the vertical angle and 30 in the horizontal angle, to 30 and 90 rays respectively in each angle. I am not using any Revit elements and there is a 0.3 offset from the edge of the surface when creating the grid.

For the purpose of this reproducible issue, I am running all possible combinations of grid size and # of rays in generative design and my output is the total number of rays cast. When I run one particular combination of these parameters in Dynamo (0.25 grid; 30x90 rays), I have no issue running the script and obtaining the resulting number of rays (= 780,300). However, in Generative Design, that particular combination of values always results in a * output despite running fine within Dynamo. I have tried running this combination both as the first one and the last one in my Generative Design permutations - with either order, I still get *.

As I mentioned, my actual issue is a bit more specific but still relates to outputs yielding a * for combinations of inputs that are particularly computationally intensive, despite getting results in Dynamo alone. Does GD have some sort of limitations to the number of computations that can be completed per run?

The other posts I have encountered on this forum regarding this issue seem to be solved by using some form of “Remember” node but that seemed to apply to Revit nodes only, and I do not have any.

The Dynamo file can be found below.

Thanks in advance!

dummy1.dyn (97.0 KB)

You might have hit the maximum RAM limit, which I think the team bumped in a later release but don’t recall. Can you try in 2024.1?

It’s likely that an alternative method for the ray casting would help here, but I would have to see the logical reason for the calf explained to know what the goal was so that the alternative would still accomplish the end result.

Thank you, I suspected that something like this was happening.

I don’t believe we have 2024.1 available at our institution yet but I will escalate this to IT if it could make a significant difference in RAM (and update this post if it does!). I have been using Revit 2023 so far because the 2024 version we have now (2024.0.5 I believe?) gives me the same error as the one described in this post: "Server is not running" error comes up when defining a Generative Design study in Revit

I am not sure at this point in time if an alternative method would still be appropriate, but I’ll think about about it with the rest of my research team.