Generative Design Error : Graphics & Output No Value

Hello

First of all, the goal of the algorithm being tested is
Finding the combination of the positions of the circles that cover a given area maximally.
(version used : Revit 2021.1.1 / DYN 2.6.1 / GD Release 21.9.4.0)

The logic shown below is extracting the number of random combinations based on the input variable.
If I manually adjust the variables in Dynamo, I can see that the results come out correctly.

By the way, if I execute the logic in Generative Design, it seems that the output value is “*, No Value” and the shape is also broken.

Does someone know how to do this?
Thank you.

If you open your graph and set the value of the random shuffle to 8, and the increasing weight to 55, what do you see in the outputs? My guess: null.

Somehow that combination of values has introduced a null along your logic stream, and so the only outputs you’re getting are *. You should do a quick ‘cross product’ study to ensure that the bulk of your outputs aren’t going to return null, and consider adding an ‘if null, return big scary value that is the worst value you could ever get + 1’ to your evaluation metrics, which will prevent GD form thinking the occasional null is good due to a low score elsewhere.

Other things to check:

  1. Have you remembered the right data?
  2. Do you have any python nodes calling an external application which GD doesn’t have access to (ie: Revit API requests, or RSA), or code which is attempting to leverage multiple cores (something GD does automatically).

Without using Generative Design,
set the value of the random shuffle to 8, and the increasing weight to 55.
I get the result like this.

As you can see in the image, the value for Output comes out well.
However, when the logic is executed in Generative Design, an error occurs with no value displayed.

I didn’t use Python nodes separately.
But as a result of checking in Dynamo Core, I got an error in the part using the BimorphNodes package.
Is the custom package related to that error?

Perhaps the Bimorph node may call the Revit API which means it won’t work in the context of Dynamo core / Sandbox which means it won’t work in Generative Design.

What is the error? Can you share the graph (including the remembered data)?

The images below show an error when run on the Dynamo core. (version : 2.7.0.9206)

When I first import data from CAD, I can see that the data is read using the BimorphNodes package,
but it does not work in the Dynamo core.

Also the package setting, Generative Design is not installed,
but I am not sure if this should be done with the old version, Refinary package.

core2

You need to remember the CAD data in order to access it in Generative Design as Generative Design has no access to the Revit API.

You can then add the Generative Design package to your Dynamo Sandbox application by adding the path from the Dynamo for Revit location to your Dynamo Sandbox node and package paths.

I’m getting a red exclamation mark when I create the generative design study using the “optimize” method (no outcomes whatsoever). I tried doing a ‘cross product’ study and all the outputs returned a *no value. I’ve therefore added an “if null, return a value that is outside the acceptable range” (the acceptable range was specified by the constraints set when creating the GD study). I ran the study again using the cross product method and also got “no value” outputs.

Please note the following:

  1. I believe that I remembered the right data.
  2. I don’t have any python nodes calling an external application.
  3. I’m not sure of this though: What do you mean by “a code attempting to leverage multiple cores (something GD does automatically)”?

Please help! Thanks!

Sounds like a graph configuration or custom node which isn’t compatible in Dynamo Sandbox. Posting your DYN is the easiest way to resolve either.

I’ve added a part to it and I’ll post the DYN file as soon as I finish it. Thanks!

Hello Jacob! I tried running the Dynamo graph using Dynamo Sandbox. It looks like the issue has something to do with either the generative design package installed or the data.remember node. I’ve attached screenshots for the packages installed and the nodes I have. I’ve also attached a screenshot for the Dynamo version (I don’t know if this helps). I’m using Revit 2022. Thank you for your continuous help!

Inputs



dynamo version

You’ll have to add the Generative Design version you’re using in Revit into your Dynamo Sandbox environment by adding the path to the same location Revit is using via the manage node and package paths settings.

If that doesn’t work post the graph here and I’ll have a look.

1 Like

I successfully installed the generative design package and all my nodes seem to be working (no warnings displayed), except for some few nodes shown in the screenshots attached. Thanks again Jacob. I really appreciate your help!


Check to make sure all the remember nodes have data in them. That data should continue downstream and you should get good results in the output nodes at the end.

Whenever you stop seeing data/results. My guess is that there is another Revit node somewhere in there which produces a null.

1 Like

I’m still trying to figure the issue out. My remember nodes have data in them. Thank you for your help! I’ll probably get back to you soon!

If you get stuck post the graph - troubleshooting via images is very difficult as you can’t get enough context.:slight_smile:

I’ll continue challenging myself before I give up! Also, I’m trying not to post it as it is part of my research dissertation! Thanks again Jacob and thank you for your understanding!

Just throwing this out there, but maybe try using a double slider with the step value at 1. I have had a few issues with the integer slider in Generative Design, (albeit in later versions of Dynamo and Revit)

2 Likes

Thank you for your suggestion. I will let you know if it works! Thanks again