Image Transparency

Hello, I have a PDF of a floor plan that I need to copy the information exactly off of into Revit. However I dont have the CAD file. So I saved the PDF as an Image and loaded that into revit. I set it as background, however, the problem is it overlays many things in the model that I dont want it to and makes it very confusing. So I want to make the image partially transparent so I can see all my model elements and the Stuff on the PDF however my graph doesnt seem to be working. Can anyone help me?

A rule of thumb: If it’s not possible within the Revit GUI, it’s most likely not possible trough Dynamo/API either.

Yep, I concur with Einar. You could reach out to Andreas, the author of the Clockwork nodes about that functionality, but I suspect that’s not a Revit capability

1 Like

Thanks guys. I didnt know if it was the new dynamo update that did it to me or not. is there anyway to check this? @Zach_Kron - its good to see you on here man!

Just checking :slight_smile:
Have you tried Send to Back in Revit?

Revit doesn’t support image Transparency. Even if you had a transparent PNG image, it would still load in with all Pixels rendered Opaque. It’s weird, but that’s what it is.

Hi Konrad

I understand Revit supports transparency in PNG, but only if it is a 32 bit PNG
I believe that means RGB, with an alpha channel

I don’t have Revit to hand to verify, but recall I have got this to work in the past. Refer:


1 Like

Yes, but it only supports Alpha channel set to either 0 or 1. Per OP question he wanted to adjust opacity and as I understand it that means setting the Alpha channel to anything between 0 and 1.

Hi Konrad

I assumied that the opaque image background was obscuring stuff, rather than linework in the image

Incidentally, although it probably depends what sort of view you are working in, ‘send to back’ works for me as expected, so the image bacground doesnt matter

@Vikram_Subbaiah Yes Ive tried that, but its still not good enough, especially with the linked Arch model also needing to be background.
@Andrew, send to back doesnt work for me, Sorry I tried that.